Bug 218036 - glibc won't allow portmap daemon to restart
glibc won't allow portmap daemon to restart
Status: CLOSED DUPLICATE of bug 217850
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-01 09:39 EST by Paul Dickson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-01 09:46:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Dickson 2006-12-01 09:39:07 EST
Description of problem:
After installing the latest glibc, if the portmap daemon is restarted (or
started) it will fail:
  "Cannot register service: RPC: Unable to receive; errno = Connection refused
   not registered:     100000    2   tcp   111   portmapper"
The above repeats for 25 more services.

Version-Release number of selected component (if applicable):
glibc-2.5.90-8

How reproducible:
Always

Steps to Reproduce:
1. sudo service portmap restart
2.
3.
  
Actual results:
First time will succeed, but each successive run will have a FAIL for shutdown.

Expected results:
OKs for both shutdown and startup.

Additional info:
This must be done for each NFS client and server to get the portmap daemon
running.  On the server, the nfs daemon must be restarted.

Wireshark is reporting checksum errors for each V2 GETPORT Reply.  It works
anyway so this might be a wireshark bug.
Comment 1 Jakub Jelinek 2006-12-01 09:46:06 EST

*** This bug has been marked as a duplicate of 217850 ***

Note You need to log in before you can comment on or make changes to this bug.