This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 217850 - portmap crashes in svc_run()
portmap crashes in svc_run()
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
: 218036 218102 218132 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-30 07:22 EST by Tim Waugh
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.5.90-10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-01 07:09:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2006-11-30 07:22:10 EST
Description of problem:
The portmap service crashes on start-up.

Version-Release number of selected component (if applicable):
portmap-4.0-65.2.2.1
glibc-2.5.90-8

How reproducible:
100%

Steps to Reproduce:
1.service portmap start
2.ps axf

Actual results:
portmap isn't running

Expected results:
portmap is running

Additional info:
[root@hoopoe ~]# gdb --args portmap -d
GNU gdb Red Hat Linux (6.5-18.fc7rh)
Copyright (C) 2006 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux-gnu"...Using host libthread_db
library "/lib/libthread_db.so.1".

(gdb) r
Starting program: /sbin/portmap -d

Program received signal SIGSEGV, Segmentation fault.
svc_run () at svc_run.c:81
81                my_pollfd[i].revents = 0;
(gdb) info source
Current source file is svc_run.c
Compilation directory is /usr/src/debug/glibc-20061128T1037/sunrpc
Located in /usr/src/debug/glibc-20061128T1037/sunrpc/svc_run.c
Contains 101 lines.
Source language is c.
Compiled with DWARF 2 debugging format.
Does not include preprocessor macro info.
Comment 1 Jakub Jelinek 2006-12-01 07:09:06 EST
Should be fixed in glibc-2.5.90-10 in rawhide.
Comment 2 Jakub Jelinek 2006-12-01 09:46:19 EST
*** Bug 218036 has been marked as a duplicate of this bug. ***
Comment 3 Jakub Jelinek 2006-12-01 15:10:25 EST
*** Bug 218102 has been marked as a duplicate of this bug. ***
Comment 4 david.hagood 2006-12-01 19:46:46 EST
Any idea WHEN this will hit Rawhide? This killed ypbind so none of my machines
can authenticate anybody but root. Don't these RPMS get any checking before
going up on the server?
Comment 5 David Lutterkort 2006-12-02 01:25:59 EST
*** Bug 218132 has been marked as a duplicate of this bug. ***
Comment 6 Jakub Jelinek 2006-12-02 02:31:49 EST
This is rawhide, you have to expect that it breaks from time to time.
glibc is being checked by its internal testsuite, but that doesn't include
svc_run testing (generally anything that requires root permissions).
If nothing breaks, it will be in 20061202 rawhide push.
Comment 7 Paul Dickson 2006-12-02 16:05:44 EST
I got the following with glibc-2.5.90-10:

[root@white 13:55:45 ~]# service portmap restart
Stopping portmap:                                          [  OK  ]
Starting portmap:                                          [  OK  ]
[root@white 13:55:58 ~]# service portmap restart
Stopping portmap:                                          [  OK  ]
Starting portmap:                                          [  OK  ]
Cannot register service: RPC: Unable to receive; errno = Connection refused
not registered:     100000    2   tcp    111  portmapper
Cannot register service: RPC: Unable to receive; errno = Connection refused
not registered:     100000    2   udp    111  portmapper
Cannot register service: RPC: Unable to receive; errno = Connection refused
not registered:     100024    1   udp    931  status
Cannot register service: RPC: Unable to receive; errno = Connection refused
not registered:     100024    1   tcp    934  status
Cannot register service: RPC: Unable to receive; errno = Connection refused
not registered:     100021    1   udp  32768  nlockmgr
Cannot register service: RPC: Unable to receive; errno = Connection refused
not registered:     100021    3   udp  32768  nlockmgr
Cannot register service: RPC: Unable to receive; errno = Connection refused
not registered:     100021    4   udp  32768  nlockmgr
Cannot register service: RPC: Unable to receive; errno = Connection refused
not registered:     100021    1   tcp  37276  nlockmgr
Cannot register service: RPC: Unable to receive; errno = Connection refused
not registered:     100021    3   tcp  37276  nlockmgr
Cannot register service: RPC: Unable to receive; errno = Connection refused
not registered:     100021    4   tcp  37276  nlockmgr
[root@white 13:55:59 ~]#

But subsequent runs still gave me:

[root@white 13:56:27 ~]# service portmap restart
Stopping portmap:                                          [  OK  ]
Starting portmap:                                          [  OK  ]
[root@white 13:56:34 ~]#

And my NFS volumes are mounted and can be remounted.

Note You need to log in before you can comment on or make changes to this bug.