Bug 2180524 - livecd-iso-to-disk says "Error 1 detected at line 2028 /usr/bin/livecd-iso-to-disk" when trying to create a Fedora 38 bootable USB stick (apparently due to package format change for Fedora 38)
Summary: livecd-iso-to-disk says "Error 1 detected at line 2028 /usr/bin/livecd-iso-to...
Status: NEW
Alias: None
Product: Fedora
Classification: Fedora
Component: livecd-tools
Version: 38
Hardware: Unspecified
OS: Unspecified
Target Milestone: ---
Assignee: Neal Gompa
QA Contact: Fedora Extras Quality Assurance
Depends On:
TreeView+ depends on / blocked
Reported: 2023-03-21 16:28 UTC by David Tonhofer
Modified: 2023-09-22 08:34 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Last Closed: 2023-05-25 18:06:53 UTC
Type: Bug

Attachments (Terms of Use)

Description David Tonhofer 2023-03-21 16:28:01 UTC
Description of problem:

On Fedora 36, I want to create a bootable USB for Fedora 37.

This immediately fails:

# livecd-iso-to-disk --format --reset-mbr Downloads/Fedora-Workstation-Live-x86_64-37-1.7.iso /dev/sdb

Source image is '/home/calvin/Downloads/Fedora-Workstation-Live-x86_64-37-1.7.iso'
Verifying image...
/home/calvin/Downloads/Fedora-Workstation-Live-x86_64-37-1.7.iso:   0f0a539212821d61fcedfda0b8409869
Fragment sums: b7843fb48cd5d5c9f8be2416df66448c25bd5d62d7877a937e6f8c8d6dfc
Fragment count: 20
Supported ISO: no
Press [Esc] to abort check.
Checking: 100.0%

The media check is complete, the result is: PASS.

It is OK to use this media.
Error 1 detected at line 2028 /usr/bin/livecd-iso-to-disk
Error 1 detected at line 2028 /usr/bin/livecd-iso-to-disk

The heroic bash script of thousands of lines reveals:

cd /tmp
rm -rf usr
ikernel=$(lsinitrd $i --unpack -f usr/lib/modules/*/kernel -v 2>&1) <-- fail here
ikernel=${ikernel%/*}; ikernel=${ikernel##*/}
rm -rf usr
cd - >/dev/null 2>&1

According to the livecd project at github, there is issue 253:


October 7, 2022: "Yes, the .iso image structure has changed with Fedora 37. A new version of livecd-iso-to-disk will be required. I'm testing that now."

However, a fix seems to not have been released yet.

(This may or may not have to do something with fedora-media-writer on windows failing to create a bootable USB stick for Fedora 37, a problem I encountered, but probably not)

Version-Release number of selected component (if applicable):


How reproducible:


Expected results

A valid USB stick with Fedora 37.

The livecd-iso-to-disk on Fedora 36 should really work properly for creating Fedora 37 USB stick as the documentation says to use it:


Comment 1 Roy A. Gilmore 2023-04-23 00:24:01 UTC
This is still a problem on Fedora 38


--- 8< --- BEGIN --- 8< ---

[root@meili Workstation]# /usr/bin/livecd-iso-to-disk --format --efi Fedora-Workstation-Live-x86_64-38-1.6.iso /dev/sdb

Source image is '/home/shared/Fedora/38/Workstation/Fedora-Workstation-Live-x86_64-38-1.6.iso'
Verifying image...
/home/shared/Fedora/38/Workstation/Fedora-Workstation-Live-x86_64-38-1.6.iso:   65f6772bfece4ba799a9617066286559
Fragment sums: fee7abd6acd22ebedcb44e18a15a87e3faa8372ce551e99ae2a83e6c8bf3
Fragment count: 20
Supported ISO: no
Press [Esc] to abort check.
Checking: 100.0%

The media check is complete, the result is: PASS.

It is OK to use this media.
Error 1 detected at line 2028 /usr/bin/livecd-iso-to-disk
Error 1 detected at line 2028 /usr/bin/livecd-iso-to-disk

--- 8< --- END --- 8< ---

Doesn't anybody test the packages *before* they are released? Why isn't a *stock* Fedora 38 Workstation iso supported on Fedora 38?

Comment 2 Ben Cotton 2023-04-25 18:20:33 UTC
This message is a reminder that Fedora Linux 36 is nearing its end of life.
Fedora will stop maintaining and issuing updates for Fedora Linux 36 on 2023-05-16.
It is Fedora's policy to close all bug reports from releases that are no longer
maintained. At that time this bug will be closed as EOL if it remains open with a
'version' of '36'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, change the 'version' 
to a later Fedora Linux version. Note that the version field may be hidden.
Click the "Show advanced fields" button if you do not see it.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora Linux 36 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora Linux, you are encouraged to change the 'version' to a later version
prior to this bug being closed.

Comment 3 David Tonhofer 2023-05-05 13:25:34 UTC
After trying again on Fedora 36 to create an USB Stick with the Fedora 38 ISO image, the only way that worked for me was using "dd" as described in https://docs.fedoraproject.org/en-US/quick-docs/creating-and-using-a-live-installation-image/

Comment 4 Luis A. Florit 2023-05-15 14:28:52 UTC
It also fails in Fedora 38 with a Fedora 38 ISO image.  These two failed for me:

livecd-iso-to-disk Fedora-Workstation-Live-x86_64-38-1.6.iso /dev/sda1

livecd-iso-to-disk --home-size-mb 1024 Fedora-Workstation-Live-x86_64-38-1.6.iso /dev/sda1

Comment 5 Luis A. Florit 2023-05-15 14:41:05 UTC
The error is caused by the command

    lsinitrd /initrd*.img --unpack -f usr/lib/modules/*/kernel -v 2>&1

Namely, the variable CONFIG_SRC failed to be set. And the reason is simply that neither $SRCMNT/isolinux/ nor $SRCMNT/syslinux/ exist at that step in the livecd-iso-to-disk script. Actually, those forlders do not exist in $SRCMNT, at all.

Comment 6 Ludek Smid 2023-05-25 18:06:53 UTC
Fedora Linux 36 entered end-of-life (EOL) status on 2023-05-16.

Fedora Linux 36 is no longer maintained, which means that it
will not receive any further security or bug fix updates. As a result we
are closing this bug.

If you can reproduce this bug against a currently maintained version of Fedora Linux
please feel free to reopen this bug against that version. Note that the version
field may be hidden. Click the "Show advanced fields" button if you do not see
the version field.

If you are unable to reopen this bug, please file a new report against an
active release.

Thank you for reporting this bug and we are sorry it could not be fixed.

Comment 7 udayb 2023-06-11 05:58:26 UTC
Not even a response here from the maintainers or anyone connected to the maintainers. I still see this issue with the Fedora 38 live image. No wonder people are moving away to Ubuntu. After nearly 20 years of using Fedora, I have decided to move away to Ubuntu on the last system on which I had been using Fedora.

Comment 8 udayb 2023-06-11 07:55:24 UTC
For future reference, the thing that actually worked for me, as also reported upthread, was:

$ dd if=<iso_file> of=/dev/sde status=progress bs=8M oflag=direct

Comment 9 Jan Kratochvil 2023-07-03 02:57:01 UTC
livecd-iso-to-disk --format --reset-mbr --overlay-size-mb 8000 --home-size-mb 2000 --unencrypted-home --livedir Fedora-MATE_Compiz-Live-x86_64-38-1.6 /root/Fedora-MATE_Compiz-Live-x86_64-38-1.6.iso /dev/sdX

Source image is '/root/arch-copy/Fedora-MATE_Compiz-Live-x86_64-38-1.6.iso'
Verifying image...
/root/arch-copy/Fedora-MATE_Compiz-Live-x86_64-38-1.6.iso:   ee14906a9f894a6c8a32a74d545e7dc1
Fragment sums: 9dc63337d2cbac425e4453254e62376bf181bf368a48481a5a9d19e92f81
Fragment count: 20
Supported ISO: no
Press [Esc] to abort check.
Checking: 100.0%

The media check is complete, the result is: PASS.

It is OK to use this media.
Error 1 detected at line 2028 /usr/bin/livecd-iso-to-disk
Error 1 detected at line 2028 /usr/bin/livecd-iso-to-disk

Comment 10 JanS 2023-07-27 08:11:13 UTC
There is an another active bug reported for the same issue: Bug 2152842 (livecd-iso-to-disk always ends with error)

It has 5 people subscribed to it and is against Fedora 37, while this one has 8 people on it, and is against Fedora 38 (previously against 36). Both are the same issue and both are unresolved. They are marked as NEW, while should already be confirmed. 

There are also discussions/issues on Github - one: https://github.com/livecd-tools/livecd-tools/issues/253 started Oct 2022, and another issue from Feb 2023: https://github.com/livecd-tools/livecd-tools/issues/262 where some kind of preliminary patch is suggested by a user.

It seams like the livecd-tools package has no active maintainers unfortunately as this looks like a relatively simple bug, but there are no responses from the maintainers to this issue for months...
livecd-tools is a package in the official Fedora repository, and Fedora itself have changed the ISO format.

livecd-iso-to-disk was always my first and preferred method of creating Live images, as I am using USB sticks with Live images for system maintenance/fix/rescue/partitioning work. You NEED to have an "overlay" to install additional administrative tools in the Live system! And livecd-iso-to-disk is the only way I know of doing this. All tutorials on the Fedora website talk about "dd" or Fedora Media Writer, but these only create barebone Live image with no overlay, thus pretty useless (no system tools like gparted, etc)

Additionally, as you cannot buy an USB sticks smaller than 32GB nowadays, it is extremely wasteful to use "dd", and thus, do not allow  putting additional files onto the stick.

Please fix this issue. It seems as a simple path issue (no syslinux and no isolinux directories in the Fedora 38 ISOs). I tried fixing it myself, but I do not have sufficient understanding of boot inner-workings to guess what file in the new Fedora ISOs are which and where should be inserted into the script. I will try the patch mentioned in the github comment...


Note You need to log in before you can comment on or make changes to this bug.