Bug 218102 - svc_run segfault
svc_run segfault
Status: CLOSED DUPLICATE of bug 217850
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-01 15:01 EST by Clark Williams
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-01 15:10:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for svc_run() bug (318 bytes, patch)
2006-12-01 15:01 EST, Clark Williams
no flags Details | Diff

  None (edit)
Description Clark Williams 2006-12-01 15:01:35 EST
Description of problem:
portmap segfaults on startup in the svc_run() routine

Version-Release number of selected component (if applicable):
glibc-2.5.90-8

How reproducible:
Always

Steps to Reproduce:
1. ensure that portmap is installed
2. run '/sbin/portmap -d'
3. watch it segfault
  
Actual results:
Segfault when attempting to run

Expected results:
portmap should run without a segfault

Additional info:
Traceback in gdb shows segfault in svc_run.c:81. Looks like my_pollfd wasn't set
after initial realloc(). Rebuilding now to check if attached patch fixes problem.
Comment 1 Clark Williams 2006-12-01 15:01:36 EST
Created attachment 142611 [details]
patch for svc_run() bug
Comment 2 Jakub Jelinek 2006-12-01 15:10:05 EST

*** This bug has been marked as a duplicate of 217850 ***

Note You need to log in before you can comment on or make changes to this bug.