Bug 218104 - Rhel 5 hts Network test failed
Summary: Rhel 5 hts Network test failed
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests)   
(Show other bugs)
Version: 5
Hardware: i686 Linux
medium
high
Target Milestone: ---
: ---
Assignee: Greg Nichols
QA Contact: Greg Nichols
URL:
Whiteboard:
Keywords:
: 219755 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-12-01 20:09 UTC by Garry Wong
Modified: 2008-07-16 21:56 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-20 00:48:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Test results (967.05 KB, application/octet-stream)
2006-12-01 20:09 UTC, Garry Wong
no flags Details
Attached is the network test log with running your two commands. (8.55 KB, application/octet-stream)
2006-12-04 21:46 UTC, Garry Wong
no flags Details
network test log (40.18 KB, application/octet-stream)
2006-12-05 22:11 UTC, Garry Wong
no flags Details
hts submit log (848.06 KB, application/octet-stream)
2006-12-06 20:02 UTC, Garry Wong
no flags Details
hts 14 test logs (4.11 MB, application/octet-stream)
2007-01-03 20:35 UTC, Garry Wong
no flags Details
hts r17 network test result (2.04 MB, application/octet-stream)
2007-01-19 16:28 UTC, Garry Wong
no flags Details
test results from passing network test with R17 (1.79 MB, application/octet-stream)
2007-01-19 16:33 UTC, Gregory Feiner
no flags Details
failing network test run with R17 (2.95 MB, application/octet-stream)
2007-01-19 16:48 UTC, Gregory Feiner
no flags Details

Description Garry Wong 2006-12-01 20:09:42 UTC
Description of problem:

Rhel 5 hts Network test failed 

Version-Release number of selected component (if applicable):

Version-Release number of selected component (if applicable): rhel5 hts 
version 5 release 9


How reproducible:


Steps to Reproduce:

1. Install rhel5 x86 beta2 without Virtualization capability onto system under 
test -ProLiant DL365 G1
2. Install rhel5 x86 beta2 onto network test server
3. Install rhel5 hts version 5 release 9 test suite onto both system under 
test and network test server (with IPV4 status ip address 10.1.1.10)
4. On network test server ---> hts  server start
5. On system under test ----> hts plan ----> hts certify --test network --
server 10.1.1.10
 
Actual results: Test failed


Expected results:Test should pass


Additional info: See attached test results

Comment 1 Garry Wong 2006-12-01 20:09:44 UTC
Created attachment 142612 [details]
Test results

Comment 2 Greg Nichols 2006-12-04 19:39:04 UTC
Changed to correct product.

Comment 3 Greg Nichols 2006-12-04 19:50:25 UTC
More information is needed:

Was the Firewall enabled on either the system under test,  or the test server?

Do lmbench tests run from the command-line?

On the Test server, run lat_tcp -s
On the system under test, run tap_tcp <server ip address>

Thanks! 




Comment 4 Garry Wong 2006-12-04 20:53:26 UTC
I got the return message bash: tap_tcp : command not found when I did "tap_tcp 
10.1.1.10" on the system under test. Please advise.

Thanks,

 

Comment 5 Greg Nichols 2006-12-04 20:55:57 UTC
Sorry, that should have been 'lat_tcp'.

Comment 6 Garry Wong 2006-12-04 21:46:49 UTC
Created attachment 142777 [details]
Attached is the network test log with running your two commands.

Comment 7 Garry Wong 2006-12-04 21:49:33 UTC
With running your two commands, I got the test passed when I did hts print --
summary or --last. But the test is short and the output.log showed errors, see 
attached.

Thanks,

Comment 8 Greg Nichols 2006-12-05 19:46:19 UTC
From the output log: 

testing nfs using 10.1.1.10...
Copying 10 x 1000 mbit files to/from 10.1.1.10
mount -o rw,intr,rsize=32768,wsize=32768,udp 10.1.1.10:/var/hts/export
/tmp/tmpFOVInhnfsdir
Mount command FAILED - returned 8192

So, it looks like the system under test failed to mount the directory 
from the test server.  What is the output from "hts server start" when
run on the test server?   Also, does the mount command work when
executed manually?


Comment 9 Garry Wong 2006-12-05 21:10:55 UTC
1) The output from "hts server start" when run on the test server:
   Starting NFS services OK
   Starting NFS quotas OK
   Starting NFS daemon OK
   Starting NFS mountd OK
   Starting httpd:     OK

2) When I executed manually "mount -o rw,intr,rsize=32768,wsize=32768,udp 
10.1.1.10:/var/hts/export/tmp/tmpFOVInhnfsdir" I got message: mount: can't 
find 10.1.1.10:/var/hts....... in /etc/fstab or /etc/mtab.

Also I could not this dir ----> /var/hts/export

Thanks,

Comment 10 Garry Wong 2006-12-05 22:09:04 UTC
I rebooted both system under test and test server. And re ran your two 
commands and the network test with command: hts certify --test network --
server 10.1.1.10. The test passed on both nics, but in the log, it seems just 
one nic to be tested. See attached rhel5networkoutput.log.

Thanks,

Comment 11 Garry Wong 2006-12-05 22:11:17 UTC
Created attachment 142895 [details]
network test log

Comment 12 Greg Nichols 2006-12-06 15:28:03 UTC
Please attach the full results produced via "hts submit".

Thanks!

Comment 13 Garry Wong 2006-12-06 20:02:42 UTC
Created attachment 142982 [details]
hts submit log

Attached is network test log created by hts submit.

Thanks,

Comment 14 Garry Wong 2006-12-06 21:02:56 UTC
What is the correct command to run network eth0 and eth1 seperately instead of 
using command hts certify --test network -- <test server ip address>?

Thanks,



Comment 15 Greg Nichols 2006-12-07 19:43:28 UTC
(In reply to comment #9)

> 
> 2) When I executed manually "mount -o rw,intr,rsize=32768,wsize=32768,udp 
> 10.1.1.10:/var/hts/export/tmp/tmpFOVInhnfsdir" I got message: mount: can't 
> find 10.1.1.10:/var/hts....... in /etc/fstab or /etc/mtab.
> 
> Also I could not this dir ----> /var/hts/export
> 
> Thanks,

The hts test server was not creating /var/hts/export in
some circumstances.

Fixed in R14.

Comment 16 Greg Nichols 2006-12-19 17:27:13 UTC
*** Bug 219755 has been marked as a duplicate of this bug. ***

Comment 17 Greg Nichols 2007-01-03 16:14:20 UTC
Please retest with HTS release 14 or later.

Comment 18 Garry Wong 2007-01-03 16:39:04 UTC
I retested with hts R14. when running hts print --last, it indicated the test 
passed on both nics (the SUT has two nics), but in the log, it showed just 
one nic was being tested.

Thanks, 

Comment 19 Irina Boverman 2007-01-03 17:22:50 UTC
Reopening based on above comments. Please provide us with the log file
referenced in #18.

Comment 20 Chris Williams 2007-01-03 17:31:49 UTC
Garry,

Can you please provide the log requested in comment#19?

Comment 21 Garry Wong 2007-01-03 20:35:59 UTC
Created attachment 144733 [details]
hts 14 test logs

Attached is hts 14 network test log.

Thanks,

Comment 22 Greg Nichols 2007-01-09 21:12:14 UTC
The --last flag was being ignored - this if fixed in R16.  Otherwise, the
attached test logs show that in run number 1, both network interfaces were run
and passed.



Comment 23 Garry Wong 2007-01-17 18:06:05 UTC
 ProLiant DL360 G5 and ProLiant DL365 were system under test to be used. 

Comment 24 Gregory Feiner 2007-01-19 16:18:36 UTC
Network test is working for me on the DL320 G5 with R17.

Comment 25 Garry Wong 2007-01-19 16:26:58 UTC
In hts 17, the resuls also indicated two nics passed network test. But in the 
output.log appears only eth0 test result was logged. 

Comment 26 Garry Wong 2007-01-19 16:28:26 UTC
Created attachment 146001 [details]
hts r17 network test result

Comment 27 Gregory Feiner 2007-01-19 16:33:01 UTC
Created attachment 146004 [details]
test results from passing network test with R17

Comment 28 Gregory Feiner 2007-01-19 16:48:12 UTC
Created attachment 146009 [details]
failing network test run with R17

Comment 29 Gregory Feiner 2007-01-19 16:51:40 UTC
So in comment 26-27 I had done a fresh OS and kit install.  Then I ran the 
cdrom test by itself and then the network test by itself.  Then I peformed a 
submit.  When I run the network test again, it fails and only results for one 
nic get logged.  These results are in comment 28.  Be aware that after the 
network test passed the first time and I did the submit, then I could no 
longer run any tests.  Every attempt to run a test resulted in the error 
below.  I had to rerun "hts plan" before I could run any tests again.

traceback (most recent call last):
  File "/usr/bin/hts", line 113, in ?
    success = hts.do(args)
  File "/usr/lib/python2.4/site-packages/hts/hardwaretest.py", line 67, in do
    return self.doCertify()
  File "/usr/lib/python2.4/site-packages/hts/hardwaretest.py", line 241, in 
doCertify
    tests = self.certification.getTests(self.options.test)
AttributeError: 'NoneType' object has no attribute 'getTests'

Comment 30 Garry Wong 2007-01-19 17:21:28 UTC
Correction: Both eth0 and eth1 test results now were logged in hts R17.


Note You need to log in before you can comment on or make changes to this bug.