Bug 218132 - portmap segfaults upon startup
portmap segfaults upon startup
Status: CLOSED DUPLICATE of bug 217850
Product: Fedora
Classification: Fedora
Component: portmap (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-01 17:23 EST by David Lutterkort
Modified: 2013-04-30 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-02 01:25:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of 'strace -f /sbin/portmap' (6.05 KB, text/plain)
2006-12-01 17:23 EST, David Lutterkort
no flags Details

  None (edit)
Description David Lutterkort 2006-12-01 17:23:54 EST
This may well turn out to be a glibc bug, but portmap is where the symptoms
appear: when I start portmap (either through the service script or directly with
/sbin/portmap) it immediately segfaults.

Running '/sbin/portmap -d' under gdb gives the backtrace
#0  svc_run () at svc_run.c:81
#1  0x00640bb7 in main (argc=Cannot access memory at address 0x0) at portmap.c:245

The line svc_run.c:81 is 'my_pollfd[i].revents = 0;'

The output of 'strace -f /sbin/portmap' is attached.

This is on a machine running

glibc-2.5.90-8
kernel-2.6.18-1.2849.fc6
portmap-4.0-65.2.2.1
Comment 1 David Lutterkort 2006-12-01 17:23:54 EST
Created attachment 142632 [details]
Output of 'strace -f /sbin/portmap'
Comment 2 David Lutterkort 2006-12-02 01:25:48 EST

*** This bug has been marked as a duplicate of 217850 ***

Note You need to log in before you can comment on or make changes to this bug.