Bug 21826 - would not let me do a workstation install on a dos partition with the anaconda update
would not let me do a workstation install on a dos partition with the anacond...
Status: CLOSED DUPLICATE of bug 19523
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-06 16:04 EST by Ben Seigal
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-06 18:09:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
what the install told me I should send you (804 bytes, text/plain)
2000-12-06 16:05 EST, Ben Seigal
no flags Details

  None (edit)
Description Ben Seigal 2000-12-06 16:04:26 EST
Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in 
run
    rc = apply (step[1](), step[2])
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 507, in 
__call__
    if todo.doInstall ():
  File "/tmp/updates/todo.py", line 1485, in doInstall
    self.fstab.makeFilesystems ()
  File "/tmp/updates/fstab.py", line 666, in makeFilesystems
    isys.umount("/mnt/loophost")
  File "isys.py", line 116, in umount
    mountCount[what] = mountCount - 1
TypeError: bad operand type(s) for -

Local variables in innermost frame:
what: /mnt/loophost
removeDir: 1

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
Comment 1 Ben Seigal 2000-12-06 16:05:26 EST
Created attachment 6114 [details]
what the install told me I should send you
Comment 2 Michael Fulbright 2000-12-06 18:09:21 EST

*** This bug has been marked as a duplicate of 19523 ***
Comment 3 Brock Organ 2000-12-21 14:37:16 EST
There is an update disk that should fix this. Download it, gzip it, dd (or
 rawrite) it to a floppy disk. When you boot into the install, specify "linux
 updates" at the boot prompt. The install will prompt you to install this floppy
 when it needs it.

 ftp://people.redhat.com/ewt/mountupd.img.gz

 It should fix this problem. Please reopen this bug if it doesn't.

Note You need to log in before you can comment on or make changes to this bug.