Bug 218416 - Installation on dual-monitor system fails
Installation on dual-monitor system fails
Status: CLOSED DUPLICATE of bug 153718
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nv (Show other bugs)
6
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
: Reopened
: 219416 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-05 02:20 EST by ols6000
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-02 16:44:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output after boot (20.62 KB, text/plain)
2006-12-12 17:34 EST, Ian Malone
no flags Details
lsmod output (3.36 KB, text/plain)
2006-12-12 17:35 EST, Ian Malone
no flags Details
Xorg log (42.65 KB, text/plain)
2006-12-12 17:37 EST, Ian Malone
no flags Details

  None (edit)
Description ols6000 2006-12-05 02:20:40 EST
Description of problem: Installing from DVD, graphical interface, nVidia NV44
(GeForce 6200) detected. Video card has both VGI and digital monitors plugged
in. Under Windows XP, digital is primary. When Fedora installation DVD boots,
info appears on digital screen. After "Probing for video card" and successfully
detecting it, both screens go almost blank-dark blue with some white dots-and
nothing further happens.

Rebooting, now info comes up on VGA screen, and installation proceeds normally.


Version-Release number of selected component (if applicable):


How reproducible: Follow steps above


Steps to Reproduce:
1. see description
2.
3.
  
Actual results: see description


Expected results: see description


Additional info:
Comment 1 ols6000 2006-12-07 17:39:31 EST
Also permanently disabled the DVI input of the monitor in question.
Comment 2 Ian Malone 2006-12-12 17:34:34 EST
Created attachment 143468 [details]
dmesg output after boot
Comment 3 Ian Malone 2006-12-12 17:35:13 EST
Created attachment 143469 [details]
lsmod output

Prove we're not running nvidia
Comment 4 Ian Malone 2006-12-12 17:37:59 EST
Created attachment 143471 [details]
Xorg log

Maybe useful?
Comment 5 Ian Malone 2006-12-12 17:49:54 EST
(Sorry about the order, forgot attachments submit separately)
Probably related, description:
Nvida N430 chipset (GeForce6150), screen corruption during RHGB and login when
using the nv driver with a monitor plugged into both Digital DVI and VGA outputs.
(Green vertical bars on gray-greenish background during RHGB, corrupted version
of the same on login).

If RHGB is diabled text boot proceeds normally, corruption still occurs on
reaching login screen.

In either case the virtual consoles Ctl-Atl-Fx can still be reached. They are
initally corrupted (scrambled white on black), but logging in at one will clear
them (typing when logging in has visible effect on scrambling). However they
will not scroll to follow the prompt. This can be worked around by switching
backwards and forwards between them, which will update them.

If the nvidia driver is used:
Without RHGB, the system behaves normally.

With RHGB, the same corruption is observed during RHGB, but the display is
normal after the nvidia logo appears. However the virtual consoles are affected
as described above.

On removing the DVI connection everything is normal as far as the login screen
(the nv driver has a dissapearing pointer to be filed separately).

Attachments above taken after booting with nv (unfortunately can't remember RHGB
vs non-RHGB).
Comment 6 Ray Strode [halfline] 2006-12-12 21:25:22 EST
*** Bug 219416 has been marked as a duplicate of this bug. ***
Comment 7 Ian Malone 2006-12-13 04:51:19 EST
Have now tried with DVI only, the nv driver and rhgb work. Problem related to
the lack of dual head support in nv driver? Is this true for the original submitter?
Comment 8 Matěj Cepl 2006-12-13 07:38:33 EST
Sorry, but you are correct. nv driver just doesn't support multihead. Period.
Comment 9 Ian Malone 2006-12-13 08:45:18 EST
Even so, would it be possible to have one display working and one display blank
rather than two corrupt displays?  It would certainly be preferable, the
fundamental problem is not the lack of display one both monitors, it's that
there is no usable display.
Comment 10 Matěj Cepl 2006-12-14 07:28:19 EST
Good idea, but I am afraid definitevely this is for upstream development. Try to
file a bug there.
Comment 11 ols6000 2006-12-15 17:54:59 EST
Regardless of driver support, FC6 installation on computer A, video card A, DVI
cable A, did permanent, hardware damage to monitor A.

Monitor A fails on another computer B + video card B, using WinXP.
Different monitor B works on computer A + video card A, using WinXP.

Therefore, there is something wrong with the FC6 installation. At the start of
the install, monitor A + video card A + cable A displayed the Fedora logo, etc.
Then the screen went blank and monitor A DVI no longer worked.

Video card A is GeForce 6200; monitor A is Viewsonic VA2012wb. FC6 install probe
detected video card as nVidia NV44 GeForce 6200. Shortly thereafter, screen went
to garbage.
Comment 12 Matěj Cepl 2006-12-20 11:05:56 EST
Hi, just to give yuo head up and that we will try to investigate this further ASAP.
Comment 13 Matěj Cepl 2006-12-20 18:11:33 EST
Hi, ols6000, we have contacted people from NVidia and even they never met their
card damaging hardware. The current prevailing suspicion is that your monitor
was already on the edge of falling apart and installation of Fedora (by having
different demands then Windows) just pushed him over.

We will continue to follow this bug, but if you have any additional information,
please, feel free to comment here.
Comment 14 ols6000 2006-12-20 20:11:21 EST
The monitor has behaved perfectly for a year, using its digital input. I don't
believe it was "on the edge of falling apart", whatever that means. I also note
that the Windows drivers had no trouble operating the monitor.

There has been a related bug posted that Fedora doesn't support dual-head video
cards.

If you are serious about investigating this bug, you will first find out what
the situation is with DVI+VGA video nVidia cards, then talk to Viewsonic about
what could make their monitor not identify itself as digital. The digital signal
paths are intact, and the monitor will display from the digital input, but only
if the computer is fooled into thinking an operating monitor is present.

If you believe that the problem is my monitor, take a monitor of your own, hook
it up to a DVI+VGA video nVidia card, and let 'er rip. It's not an experiment
I'm willing to try.
Comment 15 Ian Malone 2006-12-21 03:16:32 EST
> If you believe that the problem is my monitor, take a monitor of
> your own, hook it up to a DVI+VGA video nVidia card, and let 'er
> rip. It's not an experiment I'm willing to try.

This is exactly what I did, even to the point of manually attempting to switch
to DVI input (it didn't want to and switched back to VGA).  Monitor is AG Neovo M19.

Feedback from your manufacturer on the fault in your monitor would be useful if
it's still under warrranty.
Comment 16 ols6000 2006-12-21 12:46:04 EST
I agree that feedback would be useful, and monitor is under warranty, but would
take 1 mo to repair. Also, it's not likely Viewsonic would tell me what they
found, or that they repair at the component level. They probably just swap the
circuit board.

Since VGA input still works, I am just using it w/o DVI. Viewsonic doesn't make
service manual available, so I can't dx problem myself. I suspect there is an
output on DVI connector that signals "DVI here", and that transistor is blown.
If I had more time, I could check DVI specs and verify this hypothesis.
Comment 17 Adam Jackson 2007-04-02 16:44:31 EDT

*** This bug has been marked as a duplicate of 153718 ***

Note You need to log in before you can comment on or make changes to this bug.