Bug 218605 - HPLIP service should start on demand
HPLIP service should start on demand
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
: 224516 (view as bug list)
Depends On: 246257
Blocks: 222312 F8Target
  Show dependency treegraph
 
Reported: 2006-12-06 08:40 EST by Tim Waugh
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version: 2.7.6-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-04 13:06:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2006-12-06 08:40:26 EST
Description of problem:
The HPLIP service should only be running when an HP device it drives is
connected.  Can use HAL for that.
Comment 1 P Jones 2006-12-19 13:01:49 EST
I'm not sure if the problem I am recently experiencing has to do with this bug.
Please let me know if not and I'll file a new bug. This occurs on an up to date
(as of 12/19/06) FC6.

I can not print to a JetDirect connected HP OfficeJet 7110 All In One unless I
scan something first using XSane.

I've tried this with SElinux and firewall off, and on, the result is the same.

Setup of the printer is done using hp-setup in GUI mode, and printing a test
page right after setup works. Reboot, and then printing does not work unless
scanning first, which works fine first time.

Comment 2 Tim Waugh 2006-12-21 08:18:12 EST
Please file a separate bug report.  Thanks.
Comment 3 Tim Waugh 2007-02-05 08:48:19 EST
*** Bug 224516 has been marked as a duplicate of this bug. ***
Comment 4 Bernard Johnson 2007-05-06 15:01:33 EDT
(In reply to comment #0)
> Description of problem:
> The HPLIP service should only be running when an HP device it drives is
> connected.  Can use HAL for that.

What about network connected printers?  Can you detect them with avahi and do
the same?
Comment 5 Bastien Nocera 2007-05-08 17:29:12 EDT
(In reply to comment #4)
> (In reply to comment #0)
> > Description of problem:
> > The HPLIP service should only be running when an HP device it drives is
> > connected.  Can use HAL for that.
> 
> What about network connected printers?  Can you detect them with avahi and do
> the same?

I guess the printers would already be configured, one way or another via
system-config-printer/cups. We should be able to start up HPLIP after cups if a
printer requires it. But what about network scanners?

I guess the best bet is to make HPLIP a D-Bus service that can startup on
demand, and die when nothing uses it.
Comment 6 Bernard Johnson 2007-05-08 18:01:37 EDT
(In reply to comment #5)
> I guess the best bet is to make HPLIP a D-Bus service that can startup on
> demand, and die when nothing uses it.

I don't think that would work for things like low supply notices.  (Not sure if
hplip is even doing anything like that right now though)
Comment 7 Tim Waugh 2007-05-09 04:51:47 EDT
HPLIP does give marker-supply-low-warning notices, yes, but CUPS keeps them
persistent if HPLIP disappears after issuing them.  They are part of the CUPS
printer's printer-state-reasons attribute.
Comment 8 Tim Waugh 2007-06-29 12:51:12 EDT
HPLIP 2.7.6 is now daemon-less.

Note You need to log in before you can comment on or make changes to this bug.