Bug 218679 - No 32-bit package of nss_ldap breaks vmware, acroread, 32-bit gtk apps
No 32-bit package of nss_ldap breaks vmware, acroread, 32-bit gtk apps
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
: 219040 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-06 14:31 EST by Michael Torrie
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version: 257-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-01 10:30:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Torrie 2006-12-06 14:31:19 EST
Description of problem:
On a machine that's using LDAP as a passwd source (using nss_ldap), only the
64-bit version of nss_ldap is available, but no 32-bit version.  This means any
32-bit applications that try to do a getpwuid_r() call on the LDAP user will
always not find the username.  Thus vmware prints an error saying it cannot find
a place to write temporary log files (vmware is 64-bit aware but uses 32-bit
glib and gtk).  Acroread just spits out a GTK error about not finding a username
for the current uid.

If I copy lib/libnss_ldap* from a 32-bit FC6 machine everything works.

Version-Release number of selected component (if applicable):
253-1


How reproducible:
Just install FC6 on a 64-bit machine, configure it to use LDAP for users and
passwords, and try to run vmware as an ldap user.

Steps to Reproduce:
1. Set up LDAP in authconfig-tui
2. log in as an ldap user
3. try running vmware, or acroread (patched to fix the expr problem)
  
Actual results:
Vmware complains about no temporary location for log files, acroread complains
that user id #### doesn't exist

Expected results:
Things should load and work fine.

Additional info:
Comment 1 Michael Torrie 2006-12-06 14:49:46 EST
Eclipse also will not run either, saying it can't find the worksapce in path
/?/workspace (? because it cannot find the user's home directory or name)
Comment 2 Nalin Dahyabhai 2006-12-06 15:32:59 EST
A 64-bit Fedora Core tree should include both 32- and 64-bit versions of the
nss_ldap package.  Which architecture is your system (output of "arch")?
Comment 3 Michael Torrie 2006-12-06 16:06:12 EST
# arch
x86_64

# rpm -qa | grep nss_ldap
nss_ldap-253-1

# yum install nss_ldap.i386
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
Reading repository metadata in from local files
Parsing package install arguments
No Match for argument: nss_ldap.i386
Nothing to do

I must be doing something wrong I guess.  I have not modified the yum.repos.d
files, except to add livna and freshrpms

As a sanity check:
# rpm -qi glibc
Name        : glibc                        Relocations: (not relocatable)
Version     : 2.5                               Vendor: Red Hat, Inc.
Release     : 3                             Build Date: Sun 08 Oct 2006 09:09:32
AM MDT
Install Date: Wed 29 Nov 2006 09:01:04 AM MST      Build Host:
hs20-bc1-5.build.redhat.com
Group       : System Environment/Libraries   Source RPM: glibc-2.5-3.src.rpm
Size        : 11534911                         License: LGPL
Signature   : DSA/SHA1, Mon 09 Oct 2006 10:08:39 PM MDT, Key ID b44269d04f2a6fd2
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
Summary     : The GNU libc libraries.
Description :
The glibc package contains standard libraries which are used by
multiple programs on the system. In order to save disk space and
memory, as well as to make upgrading easier, common system code is
kept in one place and shared between programs. This particular package
contains the most important sets of shared libraries: the standard C
library and the standard math library. Without these two libraries, a
Linux system will not function.
Name        : glibc                        Relocations: (not relocatable)
Version     : 2.5                               Vendor: Red Hat, Inc.
Release     : 3                             Build Date: Sun 08 Oct 2006 09:31:30
AM MDT
Install Date: Wed 29 Nov 2006 09:01:07 AM MST      Build Host:
hs20-bc2-3.build.redhat.com
Group       : System Environment/Libraries   Source RPM: glibc-2.5-3.src.rpm
Size        : 12512698                         License: LGPL
Signature   : DSA/SHA1, Mon 09 Oct 2006 10:08:38 PM MDT, Key ID b44269d04f2a6fd2
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
Summary     : The GNU libc libraries.
Description :
The glibc package contains standard libraries which are used by
multiple programs on the system. In order to save disk space and
memory, as well as to make upgrading easier, common system code is
kept in one place and shared between programs. This particular package
contains the most important sets of shared libraries: the standard C
library and the standard math library. Without these two libraries, a
Linux system will not function.

I do have both 64-bit and 32-bit versions of libraries like glibc, etc.
Comment 4 Bill Nottingham 2006-12-06 17:19:26 EST
The distribution scripts need to include nss modules as well as pam modules, and
the update system needs modified accordingly.
Comment 5 Luke Macken 2006-12-07 13:20:24 EST
nss_db and nss_ldap have been added to the biarch list for Fedora updates (they
existed for FC4/5, but seemed to have vanished for FC6).
Comment 6 Nalin Dahyabhai 2006-12-11 12:13:01 EST
*** Bug 219040 has been marked as a duplicate of this bug. ***
Comment 7 Jesse Keating 2006-12-15 12:58:07 EST
We'll still need an update of nss stuff to pick up the multiarch packages. 
Reassigning to nalin.
Comment 8 Nalin Dahyabhai 2007-10-01 10:30:42 EDT
Hmm, should have closed this along with #219040.  Closing now.

Note You need to log in before you can comment on or make changes to this bug.