Bug 219040 - Lack of nss_ldap.i386 on x86_64
Lack of nss_ldap.i386 on x86_64
Status: CLOSED DUPLICATE of bug 218679
Product: Fedora
Classification: Fedora
Component: nss_ldap (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-09 15:27 EST by Stephen White
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-11 12:12:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Stephen White 2006-12-09 15:27:41 EST
The lack of a 32bit libnss_ldap on the x86_64 platform has caused some issues
for us.  Notably we often run a 32bit Sun JVM on the 64bit platform, as unless
we need the larger address space offered, we find it performs better than the
64bit version.

The office uses a centralized user/password database, shared via LDAP.  A 32bit
JVM attempts to obtain details such as the user's name and home directory from a
32bit libnss, and in our environment this fails without a 32bit libnss_ldap.

public class Test {
  public static void main(String[] args) {
    System.err.println(System.getProperty("user.home",""));
    System.err.println(System.getProperty("user.name",""));
  }
}

Without libnss_ldap this just returns "?" on each output line.  No doubt the
same problem will affect other 32 bit software that attempts to query the passwd
database.

Fortunately, due to Fedora's use of /lib64 for 64-bit libs, the fix is as simple
as obtaining the nss_ldap RPM from the i386 distribution of Fedora Core 6 and
installing that alongside the 64bit version.

I'm aware that there could be debate over how many 32bit libs to provide on
x86_64, but given the number of applications that are likely to expect basic
passwd database functionality to work I think that the nss_* libraries should be
included.
Comment 1 Nalin Dahyabhai 2006-12-11 12:12:59 EST
(In reply to comment #0)
> I think that the nss_* libraries should be
> included.

I agree.  Its omission was an oversight.  Marking as a duplicate of the bug
where we're tracking this.

*** This bug has been marked as a duplicate of 218679 ***

Note You need to log in before you can comment on or make changes to this bug.