Bug 218683 - SPECviewperf 9 crashes X server
SPECviewperf 9 crashes X server
Status: CLOSED DUPLICATE of bug 431340
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
8
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
http://www.spec.org/gpc/opc.static/vp...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-06 14:45 EST by Markku Kolkka
Modified: 2008-02-13 05:58 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-13 05:58:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X server log (64.53 KB, text/plain)
2006-12-06 14:45 EST, Markku Kolkka
no flags Details
X.org configuration file (717 bytes, text/plain)
2007-01-02 06:54 EST, Markku Kolkka
no flags Details
Another X crash log (62.74 KB, text/plain)
2007-03-13 02:35 EDT, Markku Kolkka
no flags Details
X configuration file (877 bytes, text/plain)
2007-03-13 02:36 EDT, Markku Kolkka
no flags Details
Xorg log file (45.71 KB, text/plain)
2007-12-10 13:09 EST, Markku Kolkka
no flags Details
current X configuration file (567 bytes, text/plain)
2007-12-10 13:10 EST, Markku Kolkka
no flags Details

  None (edit)
Description Markku Kolkka 2006-12-06 14:45:38 EST
Description of problem:
Trying to run SPECviewperf 9.0.3 on a machine with Intel G965 graphics, but
during the first viewset the X server crashes to a blank black screen. System
won't react to keyboard commands and needs a reboot.

Version-Release number of selected component (if applicable):
xorg-x11-drv-i810-1.6.5-10.fc6

How reproducible:
always

Steps to Reproduce:
1. Install SPECviewperf
2. ./Run_All.csh
  
Actual results:
The first part of the benchmark (3dsmax-04) runs for a while, then crashes to a
black screen.

Expected results:
The full benchmark suite runs to completion.

Additional info:
Intel DG965WH motherboard, Core 2 Duo E6600 processor, 2GB RAM.
X logfile attached.
Comment 1 Markku Kolkka 2006-12-06 14:45:39 EST
Created attachment 142981 [details]
X server log
Comment 2 James 2006-12-17 13:59:41 EST
Another I830WaitLpRing() error... could be related to Bug 195802, Bug 215353 et
al. When I reported an incident a few months ago it was deferred upstream. I got
one today when using Xine. They seem to happen rarely for me (i855 chipset); the
result is screen corruption and X keeps restarting. The only solution is to
Ctrl+Alt+Del the machine or reboot it cleanly from SSH.

Error in I830WaitLpRing(), now is -1850881715, start is -1850883716
pgetbl_ctl: 0x1ffe0001 pgetbl_err: 0x0
ipeir: 0 iphdr: 1810000
LP ring tail: 190 head: 0 len: 1f001 start 0
eir: 0 esr: 0 emr: ffff
instdone: ffc0 instpm: 0
memmode: 108 instps: 0
hwstam: ffff ier: 22 imr: 9 iir: 200
space: 130664 wanted 131064

FatalError re-entered, aborting
lockup

Anyone any ideas when this bug will be definitively squashed?
Comment 3 Matěj Cepl 2007-01-02 06:29:13 EST
J H Ettle, could you please file a separate bug for your issue indicating
relation to this one? Thanks a lot.

Markku, can I ask for your /etc/X11/xorg.conf as well, please?
Comment 4 Markku Kolkka 2007-01-02 06:54:20 EST
Created attachment 144635 [details]
X.org configuration file
Comment 5 Markku Kolkka 2007-03-13 02:35:21 EDT
Created attachment 149903 [details]
Another X crash log

Yesterday Google Earth crashed in a similar way. Log and configuration file
attached.
Comment 6 Markku Kolkka 2007-03-13 02:36:22 EDT
Created attachment 149904 [details]
X configuration file
Comment 7 Matěj Cepl 2007-12-10 04:22:32 EST
Fedora Core 6 is no longer supported, could you please reproduce this with the
updated version of the currently supported distribution (Fedora 7, 8, or
Rawhide)? If this issue turns out to still be reproducible, please let us know
in this bug report. If after a month's time we have not heard back from you, we
will have to close this bug as CANTFIX.

Setting status to NEEDINFO, and awaiting information from the reporter.

[This is mass-filed message to all open Fedora Core 6 bugs related to Xorg or
Gecko. If you see any other reason, why this bug shouldn't be closed, please,
comment on it here.]
Comment 8 Markku Kolkka 2007-12-10 13:08:25 EST
xorg-x11-drv-i810-2.1.1-7.fc8 in F8 still crashes in SPECViewperf 9.0.3, another
log as attachment
Comment 9 Markku Kolkka 2007-12-10 13:09:15 EST
Created attachment 283001 [details]
Xorg log file
Comment 10 Markku Kolkka 2007-12-10 13:10:25 EST
Created attachment 283021 [details]
current X configuration file
Comment 11 Matěj Cepl 2007-12-10 15:11:58 EST
thanks a lot for the update
Comment 12 Jesse Barnes 2008-01-10 17:02:43 EST
Looks like this hasn't been filed upstream, can you test with the git version 
of the intel driver and file a bug at bugs.freedesktop.org if it still occurs?

Thanks,
Jesse
Comment 13 Matěj Cepl 2008-01-11 12:32:04 EST
Jesse, this is too aggressive triaging -- you cannot ask regular F8 users to
test with git version. Most people using Fedora are not able to compile it
(actually, exactly xorg out of git is pretty bloody difficult to build).

Marrku, if you can test with the upstream drivers, go ahead, but don't sweat if
you can't.
Comment 14 Matěj Cepl 2008-02-13 05:58:55 EST

*** This bug has been marked as a duplicate of 431340 ***

Note You need to log in before you can comment on or make changes to this bug.