Bug 218844 - Review Request: python-yadis - Relying party support for the Yadis service discovery protocol
Review Request: python-yadis - Relying party support for the Yadis service di...
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Mahowald
Fedora Package Reviews List
Depends On: 218831 218839
Blocks: FE-ACCEPT 218852
  Show dependency treegraph
Reported: 2006-12-07 15:25 EST by Jeffrey C. Ollie
Modified: 2007-12-15 14:09 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-01-14 18:59:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
kevin: fedora‑cvs+

Attachments (Terms of Use)

  None (edit)
Description Jeffrey C. Ollie 2006-12-07 15:25:22 EST
Spec URL: http://repo.ocjtech.us/misc/fedora/6/SRPMS/python-yadis-1.0.1-1.fc6.spec
SRPM URL: http://repo.ocjtech.us/misc/fedora/6/SRPMS/python-yadis-1.0.1-1.fc6.src.rpm

This code implements relying party support for the Yadis[1] service
discovery protocol.  The protocol was developed for use by
decentralized URL-based identity systems, but is useful for
advertising services provided by or on behalf of a certain URL.

To learn more about Yadis, see http://www.openidenabled.com/yadis

The JanRain Python OpenID library[2] uses this library for discovery
of OpenID service endpoints.  See that library for an example of
library usage.

1. http://yadis.org/
2. http://www.openidenabled.com/openid/libraries/python/
Comment 1 Bernard Johnson 2006-12-09 17:31:35 EST
This is an unofficial review as I'm not sponsored.

rpmlint is silent on srpm.

Package mock-builds for FC6

A license file is not included with the distribution - please query upstream for

All "Must" requirements met.

Nice packaging.  This ends my review.
Comment 2 John Mahowald 2007-01-06 02:19:52 EST
- Links broken in doc/apache-config.html, linked examples were moved to

Would be nice:
- I see version 1.1.0 at http://www.openidenabled.com/yadis/libraries/python
Comment 4 John Mahowald 2007-01-13 15:35:55 EST
Packaging note from the README:
This is the last release of python-yadis as an independently
distributed package.  Future versions will come bundled with the
python-openid library.

+ License (LGPL)
+ noarch package, installs to %{python_sitelib}
+ follows python template
+ source matches upstream
+ %check passed
+ use of macros
+ follows naming guidelines
+ rpmlint clean
+ builds on x86_64

Comment 5 Jeffrey C. Ollie 2007-01-14 18:59:04 EST
Imported and built on development after I fixed some issues with python 2.5 and
elementtree.  Branches requested for FC-5 and FC-6
Comment 6 Jeffrey C. Ollie 2007-12-14 20:09:08 EST
Package Change Request
Package Name: python-yadis
New Branches: EL-4 EL-5
Updated EPEL Owners: jcollie
Comment 7 Kevin Fenzi 2007-12-15 14:09:38 EST
cvs done.

Note You need to log in before you can comment on or make changes to this bug.