Bug 21898 - f77 compiler problem
f77 compiler problem
Status: CLOSED DUPLICATE of bug 21426
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-07 12:30 EST by matthew jull
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-07 12:30:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description matthew jull 2000-12-07 12:30:08 EST
i've got a g77 compiler problem that also occurs with a demo
version of a commercial f77 compiler (Absoft). Even using a very simple 
program such as test.f :

      x=1.0
      write(*,*)x
      stop
      end

and compiling with f77  i get:

{menudo}/home/jull/toko/2por~> /usr/bin/f77 test.f
/usr/lib/gcc-lib/i386-redhat-linux/2.96/libg2c.a(open.o): In function
`f_open': open.o(.text+0x4e6): the use of `tempnam' is dangerous, better
use
`mkstemp'

       using f77 from a commercial Absoft demo compiler i get:

{menudo}/home/jull/toko/2por~> /usr/absoft/bin/f77 test.f
FORTRAN 77 Compiler 5.0, Copyright (c) 1987-2000, Absoft Corp.
This demonstration copy of Absoft Fortran 77 expires in 16 days.
/usr/absoft/lib/libfio.a(lowlevel.o): In function `_temp_file':
lowlevel.o(.text+0x10): the use of `tempnam' is dangerous, better use
`mkstemp'

the compiled program runs fine with either compiler, but i am
baffled why i should have this "warning" when compiling, other 
than to say that it looks like the compiler is using an older command 
(tempnam) to make a temporary file, while some
configuration files (or something) want it to use the more
up-to-date mkstemp command. 
    
Do you know how I could fix this problem? I use the fortran compiler
enough that it will be bothersome always having this message popping up and
I also wonder if it will have any impact on the numerical calculations
I am doing. My guess is that since it occurs with both compilers, it is not
a
compiler problem, but perhaps a library problem.

thanks,
		matthew-

p.s. i have all recent updates/patches to redhat 7 as of dec.7/2000.
Comment 1 matthew jull 2000-12-08 16:18:33 EST

*** This bug has been marked as a duplicate of 21426 ***

Note You need to log in before you can comment on or make changes to this bug.