Bug 219043 - Hard disk not found during FC6 install on Dell Optiplex 320 (SB600 SATA AHCI related)
Hard disk not found during FC6 install on Dell Optiplex 320 (SB600 SATA AHCI ...
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Prarit Bhargava
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2006-12-09 16:31 EST by Mike Herrick
Modified: 2007-11-30 17:11 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-11-02 10:39:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
dmesg output from FC6/dmesg output from Knoppix/lspci -v (38.75 KB, text/plain)
2006-12-09 16:31 EST, Mike Herrick
no flags Details
hdparm -I /dev/sda from knoppix 5.1.1 (2.55 KB, text/plain)
2007-03-10 10:56 EST, Karsten Vieth
no flags Details
lspci -v (knoppix) (6.74 KB, text/plain)
2007-03-10 10:58 EST, Karsten Vieth
no flags Details
lspci -v (5.18 KB, text/plain)
2007-03-27 15:33 EDT, Pawel Salek
no flags Details
dmesg output for kernel-2.6.20-1.2933.fc6 booted with pci=nomsi (20.51 KB, text/plain)
2007-03-27 15:34 EDT, Pawel Salek
no flags Details

  None (edit)
Description Mike Herrick 2006-12-09 16:31:02 EST
Description of problem:

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Acquire brand new Dell Optiplex 320
2. Attempt to install FC6
Actual results:

No hard disk is found on which to install FC6.

Expected results:

Hard disk is discovered and install proceeds.

Additional info:

Purchased a brand new Dell Optiplex 320 and proceeded to try and install FC6.  Install proceeds to the 
point where hard disk selection takes place and reports that no hard disks have been detected.

Verified that the BIOS (latest version available: 1.0.9) can indeed detect the 80G drive and Dell 
Diagnostics on one of the partitions report that the disk is working just fine.

Booted Knoppix V4.0.2 and it couldn't detect the drive either, but when I booted with Knoppix V5.0.1 
(2.6.17 kernel), the disk was detected just fine.  Tried to install FC5 with no luck - didn't find the disk 

Looking at the dmesg output it appears to be an issue with the ATI SB600 SATA controller and/or AHCI.  
I looked in the BIOS to see if there were any 'legacy' options that I could enable but found none.

I'm attaching one file that contains three items: the dmesg output from FC6 (failed), the dmesg output 
from Knoppix (works) and the output of 'lspci -v'.

Are there any applicable kernel arguments that I can try?
Comment 1 Mike Herrick 2006-12-09 16:31:02 EST
Created attachment 143228 [details]
dmesg output from FC6/dmesg output from Knoppix/lspci -v
Comment 2 Conke Hu 2006-12-21 12:04:28 EST
It might be a BIOS bug. You may try to report a bug to DELL.

I've just checked your attached file, and the SB600 works in native IDE mode
which means the ahci driver should work fine.

I've installed FC6 on various SB600 boards and all work except when SB600 is
configured as legacy IDE mode.

If I could duplicate this issue, I would like to help you. let me try :)
Comment 3 Mike Herrick 2006-12-21 14:44:12 EST
Unfortunately, I returned the system to Dell since I couldn't get FC6 to install
properly.  I did report the behavior to Dell (although since Knoppix was able to
run properly, it's not clear to me it's strictly a BIOS problem).
Comment 4 Tom Cross 2007-03-08 15:10:45 EST
I'm having the same problem installing the Fedora Unity re-spin of fc6.  Unless
I add "pci=nomsi" to the linux prompt the installer will not see the hard drive.

I tried the Fedora 7 test 2 installer on it too, but f7t2 couldn't get past
"/sbin/loader" stage.

The BIOS on my Optiplex 320 is version 1.1.2
Comment 5 Karsten Vieth 2007-03-10 10:56:11 EST
Created attachment 149775 [details]
hdparm -I /dev/sda from knoppix 5.1.1
Comment 6 Karsten Vieth 2007-03-10 10:57:21 EST
I'm having the same problem installing fc7 test1, test2, fc6 respin
No Harddisk detected
Controller ATI SB600

Knoppix 5.1.1 2007-01-04 (2.6.19) works fine
Comment 7 Karsten Vieth 2007-03-10 10:58:48 EST
Created attachment 149776 [details]
lspci -v (knoppix)
Comment 8 Pawel Salek 2007-03-27 15:33:05 EDT
Created attachment 151069 [details]
lspci -v

I see the problem as well. I attach the lspci output. I could boot the box only
with lilo (see separate bug report on grub). adding "pci=nomsi" makes Linux
recognize the disks. I have another box with SB600 (HP dc5750) and it does not
require this option to run (but it did need irqpoll to boot FC6 with the
original kernel). Also, the graphics card runs in vesa mode only, radeon driver
does not recognize the card.
Comment 9 Pawel Salek 2007-03-27 15:34:48 EDT
Created attachment 151070 [details]
dmesg output for kernel-2.6.20-1.2933.fc6 booted with pci=nomsi

dmesg output for completness.
Comment 10 Allen Kistler 2007-04-20 17:06:40 EDT
I was able to get FC6 to install on an Optiplex 320 using the kernel arg
all-generic-ide.  That worked up to (including) kernel-2.6.19-1.2911.6.5.  With
the first 2.6.20 kernel, it broke.

My Optiplex works again with 2.6.20-1.2944.  There's a new line in my
modprobe.conf that reads "alias scsi_hostadapter ahci" and my drives show up as
sd? instead of hd?.

The list of bug watchers is lengthy.  If others can get similar results, then I
suppose someone (not the reporter, Comment#3 ?) can close this bug.  I think the
video bug in Comment#8 is a different bug.
Comment 11 Craig White 2007-06-30 19:25:18 EDT
similar issues with Fedora 7 and this is what I have done to make it work

1. bootup passing options 'pci=nomsi acpi=off'

2. Installed without LVM (LVM might work but I wanted to simplify things)

3. Never could get it to boot up with grub so I ended up installing lilo-22.8

Seems to be working just fine (drive of course shows up as /dev/sda)

Video seems to work OK
Comment 12 Prarit Bhargava 2007-07-11 14:19:55 EDT
There have been several updates to libata, quirks, etc., in the past few months.
 Could someone on this bug please grab a recent rawhide development kernel (not
2.6.22 based as there appear to be some other issues with the initial backport)
and attempt to boot the kernel?

I'd like to know if there are still any outstanding sb600 related issues.


Comment 13 Prarit Bhargava 2007-07-17 09:33:59 EDT
Just wondering if anyone has had a chance to try out my suggestion in comment #11?

Comment 14 Karsten Vieth 2007-07-17 10:40:17 EDT
I'm downloading the kernel linux- (is this what the version you
mean?) from kernel.org and try to compile it with my config-2.6.21-1.3228.fc7.
Comment 15 Prarit Bhargava 2007-07-17 10:49:17 EDT
Hi Karsten,

No -- that is not what I mean.

Go here and grab the latest Fedora development kernel:


Alternatively, you can also try installing over ftp using this iso:


Comment 16 Karsten Vieth 2007-07-17 14:52:22 EDT
Hi Prarit, thx for your help,
i've tried to boot with 
but after loading initrd.img nothing happend.

Also i've trried to install the newest kernel from 
with no params
kernel /vmlinuz-2.6.23-0.15.rc0.git1.fc8 ro root=/dev/VolGroup00/LVMroot rhgb quiet
But the last message i've got is: 
decompressing linux   done
booting the kernel

and nothing more
Best regards
Comment 17 Prarit Bhargava 2007-07-17 14:58:12 EDT
Karsten, remove "rhgb quiet" from the boot parameters and replace them with "debug"

Comment 18 Prarit Bhargava 2007-10-25 09:05:02 EDT
I've been able to install F8T3 (Fedora 8 Test 3) on several sb600 systems and
haven't seen any issues.  It just occurred to me that the sb600 may not have
been supported back in F6.

Please try F8T3 and let me know the results.
Comment 19 Mike Herrick 2007-11-02 09:49:55 EDT
I'd love to try this out, but I returned the system to Dell about a year ago. 
Someone else will have to give it a try.

Comment 20 Tom Cross 2007-11-13 11:34:39 EST
I tried this out with the Fedora-8 installer.  With the 'pci=nomsi acpi=off'
options I was able to get Fedora-8 installed without trouble.

However, F8 installed grub by default which was unable to boot the F8 install.
Comment 21 Craig White 2007-11-13 21:04:59 EST
Tom - methinks you are wasting your time here.

they closed this as notabug quite some time ago.

you probably want to look at here...(kernel maintenance)

and here...(general - i.e. grub issues)

these are both open bugs

Note You need to log in before you can comment on or make changes to this bug.