Bug 219049 - Don't remove scriptreplay from util-linux
Don't remove scriptreplay from util-linux
Status: CLOSED DUPLICATE of bug 181447
Product: Fedora
Classification: Fedora
Component: util-linux (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-09 22:11 EST by Jeff Moe (jebba)
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-14 06:29:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Moe (jebba) 2006-12-09 22:11:03 EST
Description of problem:
scriptreplay does not appear in the util-linux package.

Version-Release number of selected component (if applicable):
2.13-0.45.1.fc6

Steps to Reproduce:
1. Run `scriptreplay`
  
Actual results:
Not found.

Expected results:
The program would be there.

Additional info:
scriptreplay is a part of the upstream util-linux package. It is mentioned in
the `script` man page and `script` has a "-t" option which creates output for
`scriptreplay`.

In the util-linux.spec, `scriptreplay` is manually removed and marked
deprecated. But it's not deprecated upstream. Most of the other programs marked
deprecated there appear in other packages (e.g. `shutdown`, `sln`, `newgrp`, etc).

util-linux.spec:
# deprecated commands
for I in /sbin/cfdisk /sbin/fsck.minix /sbin/mkfs.{bfs,minix} /sbin/sln \
        /usr/bin/chkdupexe %{_bindir}/line %{_bindir}/pg %{_bindir}/newgrp \
        /sbin/shutdown %{_bindir}/wall %{_bindir}/scriptreplay; do
        rm -f $RPM_BUILD_ROOT$I
done

It also has a man page included in util-linux which should be added.

Thanks!
Comment 1 Karel Zak 2006-12-14 06:29:32 EST
Perl :-( For more details see the bug #181447.

*** This bug has been marked as a duplicate of 181447 ***

Note You need to log in before you can comment on or make changes to this bug.