Bug 181447 - Include scriptreplay
Include scriptreplay
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: util-linux (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
Ben Levenson
: FutureFeature
: 219049 219904 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-14 03:33 EST by Behdad Esfahbod
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-15 06:15:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Behdad Esfahbod 2006-02-14 03:33:56 EST
Description of problem:

There's this perl script written by a debian maintainer that
replays typescript and timing data gathered by script(1).
Would be nice to include it.

Version-Release number of selected component (if applicable):
util-linux-2.12p-9.13
Comment 1 Karel Zak 2006-02-14 04:49:05 EST
Please, include the script to our bugzilla as attachment. Thanks.
Comment 2 Behdad Esfahbod 2006-02-14 18:33:59 EST
Seems like it has been accepted upstream.  It is in
http://www.kernel.org/pub/linux/utils/util-linux/util-linux-2.12r.tar.bz2 for
example, under misc-utils/scriptreplay.
Comment 3 Karel Zak 2006-02-15 06:15:58 EST
Ah, sorry. I know this script :-) The problem is that it's perl script and I
think we don't want to create dependence on Perl for basic packages (like
util-linux). Sorry. WONTFIX.
Comment 4 Behdad Esfahbod 2006-02-15 19:10:23 EST
Makes sense.  I'll try to rewrite it in C :)
Comment 5 Adam Spiers 2006-03-24 18:51:35 EST
Forgive me for saying it, but C rewrites aside, I don't believe this is the
right resolution.  The tiny minority of folks who decide not to install Perl
(and I'm struggling to imagine why they wouldn't - do you know of anyone like
this?) are extremely unlikely to care if they're missing this replay
functionality.  OTOH, there's a much bigger chance that some folks who do have
Perl would like this functionality but are being deprived of it just because of
a technicality regarding dependencies.

I notice with interest that SUSE 10.0 has included scriptreplay and even quite
happily introduced a dependency on Perl from util-linux.

Just my opinion, anyhow.
Comment 6 Behdad Esfahbod 2006-03-24 20:40:51 EST
For what it's worth, I've got the functionality added to script(1) itself as a
commandline argument.  I will submit it here and then upstream after cleaning it
up a bit.
Comment 7 Karel Zak 2006-12-14 06:29:35 EST
*** Bug 219049 has been marked as a duplicate of this bug. ***
Comment 8 Karel Zak 2007-04-06 06:19:53 EDT
*** Bug 219904 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.