Bug 21906 - New glibc-2.2 break down Xconfigurator
New glibc-2.2 break down Xconfigurator
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Aaron Brown
:
: 21829 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-07 15:41 EST by Milan Kerslager
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-08 17:01:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Milan Kerslager 2000-12-07 15:41:23 EST
I found that glibc-2.2 from RH's update break down Xconfigurator. No
testing screen at the end, only message about failed test of the new
configuration (but configuration is OK when trying to start X manually
after this).

Xconfigurator leave then empty X server running so next X session go to the
next free console.

Downgrading to glibc-2.1.92-14 from vanilla 7.0 solve the problem.
Recompilation desn't help at all.
Comment 1 Jakub Jelinek 2000-12-08 06:03:47 EST
I believe this is a bug in Xconfigurator (well, Xtest) and the fact that with
different glibcs it works differently is just a pure timing/memory layout issue.
Basically, Xtest does:
    if (!nostart) {
        waitpid(childpid, &status, WNOHANG);
        if (WIFEXITED(status)){
            return ERROR;
        }
    }
where status is uninitialized local variable. waitpid, if it returns anything
<= 0, does not modify the int pointed by second argument though, so this code
(in this case waitpid returns 0) worked by pure luck.
As I don't know exactly what this code is trying to do, I can only suggest
either if (waitpid() > 0 && WIFEXITED(status)) { return ERROR; }
or pid = waitpid(); if (pid < 0 || (pid > 0 && WIFEXITED(status))) { return ERROR; }
Trond, this would be probably worth issuing a bugfix errata I think.
Comment 2 Trond Eivind Glomsrxd 2000-12-08 17:01:52 EST
I've made some changes to CVS which should fix it...
Comment 3 Trond Eivind Glomsrxd 2000-12-10 22:24:45 EST
And built it - Xconfigurator 4.4.6. Currently available from
http://people.redhat.com/teg/ , soon from Rawhide and mirrors. Errata later.
Comment 4 Milan Kerslager 2000-12-13 18:09:07 EST
*** Bug 21829 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.