Bug 219060 - Update to 0.7.6-4
Update to 0.7.6-4
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: linuxwacom (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Aristeu Rozanski
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-10 01:44 EST by Matthias Clasen
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.7.6.4-3.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-17 23:21:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (39.98 KB, text/plain)
2007-07-25 11:05 EDT, A. Lok
no flags Details
my xorg.conf file (1016 bytes, application/octet-stream)
2007-07-25 11:08 EDT, A. Lok
no flags Details

  None (edit)
Description Matthias Clasen 2006-12-10 01:44:01 EST
Versions prior to 0.7.6-3 have an idiotic feature where they encode vendor id
and serial number information in the high bits of some axes, rendering tablets
nonfuncitonal with most applications that don't know about this "feature".

See
http://bugzilla.gnome.org/show_bug.cgi?id=344354
and
http://sourceforge.net/tracker/index.php?func=detail&aid=1592814&group_id=69596&atid=525124
Comment 1 Luis Villa 2007-06-04 09:27:12 EDT
Upgrading will also fix rotation for tabletPCs, which is critical. Will attach
spec file and updated build patches.
Comment 2 Luis Villa 2007-06-04 09:37:18 EDT
Actually, just grab the srpm:
http://tieguy.org/files/linuxwacom-0.7.6_4-1.src.rpm

Has updated spec and patches.
Comment 3 Christopher Brown 2007-07-17 06:25:43 EDT
Version 0.7.8 has recently been released. Please can this be updated soonish... :)
Comment 4 Gian Paolo Mureddu 2007-07-20 15:59:09 EDT
Will an update cascade to F7/FC6 machines as well? I had to manually install
v0.7.6 in one FC6 box and I'm currently running (manually installed) v0.7.8 on
my main F7 system.
Comment 5 Aristeu Rozanski 2007-07-23 14:06:48 EDT
It's updated to 0.7.6 and now I'm working on 0.7.8. Please test and open new
tickets in case of problems.
Comment 6 Christopher Brown 2007-07-23 16:35:51 EDT
Will 0.7.8 include wacomcpl?

Please see:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=220706

for work done on this.
Comment 7 Luis Villa 2007-07-23 16:39:19 EDT
Really, this should be a dup of bug 220706, given the amount of activity there.
(Though why that was not marked a dup of this ages ago, before the activity and
the duplication of effort is unclear.)
Comment 8 Aristeu Rozanski 2007-07-23 16:41:50 EDT
(In reply to comment #6)
> Will 0.7.8 include wacomcpl?
> 
> Please see:
> 
> https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=220706
> 
> for work done on this.
Yes, I'll. I'll also merge the changes proposed in some package review tickets
to the spec file.
Comment 9 Fedora Update System 2007-07-25 01:09:11 EDT
linuxwacom-0.7.6.4-2.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 10 A. Lok 2007-07-25 11:05:17 EDT
Created attachment 159933 [details]
Xorg.0.log
Comment 11 A. Lok 2007-07-25 11:06:12 EDT
The X driver 'wacom' doesn't load with linuxwacom-0.7.6.4-2.fc7 (i386).

I added the following to my xorg.conf:

Section "ServerLayout"
...
	InputDevice    "Stylus"    "SendCoreEvents"
EndSection

Section "InputDevice"
	Driver	    "wacom"
	Identifier  "Stylus"
	Option      "Device"	"/dev/input/wacom"
	Option	    "type"	"stylus"
	Option	    "USB"	"on"
EndSection

I noticed after restarting X that the stylus wasn't in absolute mode. Xorg.0.log
shows the following:
(II) LoadModule: "wacom"
(II) Loading /usr/lib/xorg/modules/input//wacom_drv.so
dlopen: /usr/lib/xorg/modules/input//wacom_drv.so: undefined symbol:
__stack_chk_fail_local
(EE) Failed to load /usr/lib/xorg/modules/input//wacom_drv.so
(II) UnloadModule: "wacom"
(EE) Failed to load module "wacom" (loader failed, 7)

Comment 12 A. Lok 2007-07-25 11:08:32 EDT
Created attachment 159935 [details]
my xorg.conf file
Comment 13 Christopher Brown 2007-07-25 11:17:22 EDT
You do not need to edit your xorg.conf file. The wacom driver is included in the
kernel. The linuxwacom package provides additional functionality.

You should remove the above section and if your tablet still fails then file a
new bug rather than adding to an existing one.
Comment 14 A. Lok 2007-07-26 15:57:57 EDT
(In reply to comment #13)
> You do not need to edit your xorg.conf file. The wacom driver is included in the
> kernel. The linuxwacom package provides additional functionality.

Afaik I _do_ need to edit my xorg.conf file, because I want to use this extra
functionality. Else it just functions as a normal mouse. 
 
> You should remove the above section and if your tablet still fails then file a
> new bug rather than adding to an existing one.

I don't have any problems whatsoever with the wacom kernel-module, but with the
X wacom driver. (or whatever it is called) Yes my wacom functions without adding
anything to xorg.conf, but only as a mouse. It even functions without the whole
linux-wacom package, but still only as a mouse.

Or is it now somehow possible to use my tablet in absolute mode without
modifying anything to my xorg.conf? That would be new to me.
Comment 15 A. Lok 2007-08-19 16:30:05 EDT
On second hand, the "__stack_chk_fail_local"-problem I added here, doesn't
totally fit under the problem of this bug titled as "Update to 0.7.6-4".

I've created an  new bug for this problem:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=253455

Sorry for the confusion.
Comment 16 Fedora Update System 2007-08-24 01:31:06 EDT
linuxwacom-0.7.6.4-3.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Aristeu Rozanski 2007-09-10 16:29:59 EDT
This ticket is for devel version of linuxwacom. Currently in rawhide,
0.7.8.3-2.fc8 is available.
Comment 18 Fedora Update System 2007-09-17 23:21:56 EDT
linuxwacom-0.7.6.4-3.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.