Bug 219075 - [patch] pup mouse scroll activates the no updates tab
[patch] pup mouse scroll activates the no updates tab
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
6
All Linux
medium Severity low
: ---
: ---
Assigned To: Jeremy Katz
:
: 217980 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-10 09:15 EST by David Timms
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-11 13:08:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
3x file diff -u patch pup.py pup.glade Changelog (1.77 KB, patch)
2006-12-10 09:15 EST, David Timms
no flags Details | Diff

  None (edit)
Description David Timms 2006-12-10 09:15:04 EST
Description of problem:
The mouse scroll down causes pup to show the ~"no updates" text.

Version-Release number of selected component (if applicable):
pirut-1.2.8-1.fc6

How reproducible:
Yes.

Steps to Reproduce:
1. pup {Assume there is updates available, and they get shown}
2. hold mouse over the horizontal splitter
3. scroll up -> nothing happens
4. scroll down
  
Actual results:
pup body changes to the "There are no updated packages currently available for
your system" 

Expected results:
No change.

Additional info:
By making the tabs visible, I found that the mouse scroll event by default is
used to perform tab next and previous functions. However, once scroll down event
has fired the "no updates" pages is active, and there is no way to get back to
the updates list.

Adding the notebook on_scroll event, and then responding to it by doing nothing
solves the problem, by overriding the default gtk behaviour.

ps. Being a python/gtk newcomer there may be a more effective way to achieve
this, however the attached patch does get the job done.
Comment 1 David Timms 2006-12-10 09:15:04 EST
Created attachment 143241 [details]
3x file diff -u patch pup.py pup.glade Changelog
Comment 2 Jeremy Katz 2006-12-11 13:08:32 EST
Looks good and committed.  Thanks for the patch!
Comment 3 Jeremy Katz 2007-04-09 16:38:21 EDT
*** Bug 217980 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.