Bug 219106 - rss-glx not working in KDE
rss-glx not working in KDE
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rss-glx (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-10 19:02 EST by Richard Allen
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-14 18:16:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Allen 2006-12-10 19:02:09 EST
Description of problem:
rss-glx screensavers do not work under KDE

Version-Release number of selected component (if applicable):
rss-glx-0.8.1.p-6.fc6
rss-glx-xscreensaver-0.8.1.p-6.fc6
rss-glx-kde-0.8.1.p-6.fc6
rss-glx-gnome-screensaver-0.8.1.p-6.fc6

How reproducible:
Every time

Steps to Reproduce:
1. Install FC6, KDE and rss-glx
2. Log in to KDE, open the screensaver preferences
3. All regular GL screensavers work, RSS ones do not.
  
Actual results:
Not even the preview of the screensavers in the little previw window works
The full screen preview does not either.
And after the Idle timeout kicks in, the screensaver does not start

Expected results:
Working RSS screensavers

Additional info:
I can however start all the screensavers manually from the command line and then
they work.
Comment 1 Julian Sikorski 2006-12-26 15:37:18 EST
This problem is caused by the fact that rss-glx-kde .desktop files invoke
kxsconfig, which is provided by kdeartwork-extras. The thing is that
kdeartwork-extras is not required by rss-glx-kde. Other thing here is that
kdeartwork-extras pulls xscreensaver-extras and xscreensavergl-extras, so IMHO
the better way would be to package kxsconfig for instance with kdeartwork (that
would require cooperating with core maintainers, though). Hope that helps.
Comment 2 Julian Sikorski 2006-12-26 15:59:19 EST
I have filed an appropriate bug report, see bug #220784.
Comment 3 Richard Allen 2007-01-01 21:53:24 EST
Great :)    Installing kdeartwork-extras fixed my problem :)
Thanks alot :)
Comment 4 Nils Philippsen 2007-09-14 18:16:53 EDT
current rss-glx-kde packages should have the needed requirements
Comment 5 Fedora Update System 2007-09-17 11:41:09 EDT
rss-glx-0.8.1.p-11.fc7, xscreensaver-5.03-6.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2007-09-28 17:22:15 EDT
rss-glx-0.8.1.p-11.fc7, xscreensaver-5.03-6.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.