Bug 220784 - Please move kxsconfig and friends to own (sub)package
Please move kxsconfig and friends to own (sub)package
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kdeartwork-extras (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rex Dieter
Ben Levenson
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-26 15:55 EST by Julian Sikorski
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-26 11:55:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Julian Sikorski 2006-12-26 15:55:16 EST
Please also see bug #219106. The problem is that kxsconfig in also needed by
rss-glx-kde, and keeping the program in -extras subpackage is forcing the user
to install xscreensaver stuff. In my opinion it is an unwanted state of affairs,
because the user is apparently using KDE screensaver so xscreensaver is rather
an unwanted dependency here. Cheers.
Comment 1 Rex Dieter 2007-01-01 12:42:48 EST
To build/include kxsconfig, kdeartwork needs BR: xscreensaver which isn't
available for Core 6.  (It can/will be for F7).

We *can* however, make a kdeartwork-kxsconfig subpkg for rss-glx-kde to depend
on. (Though I'm not entirely sure if that in itself would be sufficient to make
rss-gls-kde function fully).
Comment 2 Rex Dieter 2007-01-01 12:50:41 EST
Just checked rss-glx, rss-glx-kde already 
Requires: rss-glx-xscreensaver
which
Requires: xscreensaver-base
So making the change you propose wouldn't reduce dependencies much (you would
get out of xscreesaver-extras*)

I don't consider this small of a gain worth messing with really.
Comment 3 Rex Dieter 2007-01-01 12:52:38 EST
OK, changed my mind.  (:  I'll look into the kdeartwork-ksxconfig subpkg option.
Comment 4 Rex Dieter 2007-01-02 23:04:34 EST
%changelog
* Tue Jan 02 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.5.5-3
- -kxs subpkg (#220784)
- BR: libart_lgpl-devel

To be clear, new subpkg is named kdeartwork-kxs, which
Requires: xscreensaver-base

kdeartwork-extras now also
Requires: kdeartwork-kxs

This should get you the separation you wanted.

I'll push this to devel branch, and let it simmer for awhile.  If we hear no
screams of horror after ~1 week, I'll push it to FC-5/FC-6 branches too. 
Comment 5 Julian Sikorski 2007-01-03 12:51:53 EST
Just to be 1000% sure: xscreensaver-base is required as a runtime dependency as
well, or just as a build one?
Comment 6 Rex Dieter 2007-01-03 13:56:26 EST
xscreensaver-base is both a runtime and buildtime dependency.  

There may be ways of getting rid of the runtime dependency if that's a problem.
Comment 7 Julian Sikorski 2007-02-21 18:47:33 EST
Shall we close this?
Comment 8 Rex Dieter 2007-02-22 11:57:52 EST
I lied, I hadn't pushed this to FC-5/FC-6 yet as promised, but will soon, then
I'll close it.
Comment 9 Rex Dieter 2007-02-26 11:55:29 EST
FC-6 build queued.

Note You need to log in before you can comment on or make changes to this bug.