Bug 219161 - [KDE][x86_64] Formula selector vanishes upon left click - OOo formula
[KDE][x86_64] Formula selector vanishes upon left click - OOo formula
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-11 11:46 EST by Sammy
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 2.0.4-5.5.10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-04 03:43:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 72505 None None None Never

  None (edit)
Description Sammy 2006-12-11 11:46:34 EST
Description of problem:

When I choose to insert or edit a formula using the formula editor
in OO the selector comes up but as soon as I click anywhere on the
window it dissappears.

I am on a x86_64 system with FC6 and all of the updates applied.

Version-Release number of selected component (if applicable):

openoffice.org-core-2.0.4-5.5.3

How reproducible:

Every time

Steps to Reproduce:
1. Start ooimpress or oowriter
2. Choose Insert-->Object-->Formula
3. Click on the selector window
  
Actual results:


Expected results:


Additional info:
Comment 1 Caolan McNamara 2006-12-11 12:08:51 EST
I can't seem to see a problem with my setup. Though clicking outside the formula
area, i.e. in the main window of the "host" document returns as expected to the
host document view.

So, when you say "the selector" do you mean the floating window titled
"Selection" in the english version ?, and when you say "the window" do you mean
that same "Selection" window ? 

Maybe this is specific to a particular window manager or desktop environment. If
so then running 

> /usr/lib/openoffice.org2.0/program/crash_report -stack /dev/null

will throw up the crash dialog filled in with some possibly useful information.
Comment 2 Sammy 2006-12-11 12:27:45 EST
 Yes, I mean the small window titled "Selection", which allows you to choose
 various formula expressions. When I click on the main window it also goes to
 the host document. Everything else about using the formula editor is fine
 except this selection window.

Here is the output of this command (lib64 instead of lib):
===========================================================================
---start copy and paste here---
(I)    x.org loaded video driver of...
(II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
(III)  Desktop is: not GNOME
(IV)   libgcj version is: libgcj-4.1.1-30-i386 libgcj-4.1.1-30-x86_64
(V)    kernel is: Linux 2.6.18-1.2859.fc6 #1 SMP Tue Dec 5 13:52:51 CST 2006
x86_64 x86_64 x86_64
(VI)   OpenOffice.org core rpm version is: openoffice.org-core-2.0.4-5.5.3-x86_64
(VII)  depth of root window:    24 planes
(VIII) accessibility is: false
(VIV)  fedora release is: Fedora Core release 6 (Zod)
...start sestatus details ...
SELinux status:                 disabled
...end sestatus details ...
...start stackreport details ...
...end stackreport details ...
...start sample ldd details ...
        libuno_sal.so.3 => /usr/lib64/openoffice.org2.0/program/libuno_sal.so.3
(0x00002aaaaaccd000)
        libuno_salhelpergcc3.so.3 =>
/usr/lib64/openoffice.org2.0/program/libuno_salhelpergcc3.so.3 (0x00002aaaab0c2000)
        libstore.so.3 => /usr/lib64/openoffice.org2.0/program/libstore.so.3
(0x00002aaaab2c6000)
        libdl.so.2 => /lib64/libdl.so.2 (0x00002aaaab50e000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00002aaaab712000)
        libstlport_gcc.so =>
/usr/lib64/openoffice.org2.0/program/libstlport_gcc.so (0x00002aaaab92c000)
        libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00002aaaabc06000)
        libm.so.6 => /lib64/libm.so.6 (0x00002aaaabf08000)
        libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00002aaaac18b000)
        libc.so.6 => /lib64/libc.so.6 (0x00002aaaac399000)
        libcrypt.so.1 => /lib64/libcrypt.so.1 (0x00002aaaac6e7000)
        /lib64/ld-linux-x86-64.so.2 (0x0000555555554000)
...end sample ldd details ...
---end copy and paste here---
============================================================================
Comment 3 Sammy 2006-12-11 12:28:11 EST
Sorry, using KDE!
Comment 4 Caolan McNamara 2006-12-11 13:12:15 EST
Hmm, what's the *exact* focus handling setting under KDE ? Is it one of the
non-default ones, i.e. focus follows mouse, or something like that ? I don't
suppose that you have a i386 one to see if it happens only on x86_64 or on all
platforms.
Comment 5 Sammy 2006-12-11 17:17:33 EST
OK. The problem is not happening on i386 systems with the same software
installed.

I tried different focus follows options and did not make any difference.

One thing I noticed is that on i386 the Selection window has the usual
window decoration from the style, whereas on x86_64 it looks like something
generic.
Comment 6 Caolan McNamara 2006-12-12 04:04:52 EST
reproducable, as you say x86_64 + KDE
Comment 7 Sammy 2006-12-12 09:48:25 EST
Here is how I can fix it under KDE:

Control Center--->Window-Specific Settings
Press "New"
start oomath and make sure Selection window is visible
Press "Detect"
Move the mouse pointer to the Selection window and click. You'll get some
messages saying this is a "Splash Screen", say OK.
Go to "Workarounds" tab
Choose:
Focus stealing prevention        Force           Normal
Window Type                      Force           Normal Window

press OK and then apply.
Restart oomath and now it works fine.
Comment 8 Caolan McNamara 2006-12-12 11:25:14 EST
That was exactly the piece of info to crack this, will be in the update >= 
2.0.4-5.5.9.
Comment 9 Sammy 2006-12-15 11:11:44 EST
Is this being pushed through soon?

I also noticed that KDE has committed a OO related bug fix to kwin for
crashes during splash screen (KDE bug #138834).

Thanks

Note You need to log in before you can comment on or make changes to this bug.