Bug 219269 - Unknown Group "netdev" in message bus configuration
Unknown Group "netdev" in message bus configuration
Status: CLOSED DUPLICATE of bug 219218
Product: Fedora
Classification: Fedora
Component: avahi (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Bacovsky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-12 06:18 EST by Roffe Moshe
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-18 12:07:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roffe Moshe 2006-12-12 06:18:16 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

Description of problem:
after, dbus yum upgrade, on version 1.0.1-2.fc6
there is a warning that is loged on the screen that say:
Unknopwn group "netdev" in message bus configuration.

after that GDM appears but you can't login to KDE or GNOME (it hangs in the middle and that it complains about DCOP,etc..).

adding the group using
#groupadd netdev

clears the issue and you can login again.

the problem must be fixed soon. many people (un-technical) after doing yum update, won't be able to login to their desktop. 


Version-Release number of selected component (if applicable):
dbus-1.0.1-2.fc6

How reproducible:
Always


Steps to Reproduce:
1. do yum update to dbus
2. reboot, or restart the messagebus (/etc/init.d/messagebus restart)
3. restart X
4. you can't login at the GDM

Actual Results:
KDE or GNOME hnags in the middle.
dbus-daemon --system, seem to appear in ps, but it doesn't work.

Expected Results:
normal login.

Additional info:
the workaround appeared at:
http://lists.alioth.debian.org/pipermail/pkg-utopia-maintainers/2006-September/000274.html
Comment 1 John (J5) Palmieri 2006-12-14 12:59:44 EST
<policy group="netdev"> is in /etc/dbus-1/system.d/avahi-dbus.conf.  This is a
debianism.  Avahi changed its security profile upstream.  I think we need a
policy from now on dealing with auditing anything that goes into
/etc/dbus-1/system.d/.  Please grab the old service file and rebuild this for
fedora.
Comment 2 Bastien Nocera 2006-12-18 12:07:41 EST

*** This bug has been marked as a duplicate of 219218 ***

Note You need to log in before you can comment on or make changes to this bug.