Bug 219218 - Updated avahi package does not create group "netdev"
Updated avahi package does not create group "netdev"
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: avahi (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Bacovsky
:
: 219269 219764 219991 220204 222790 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-11 17:39 EST by Anand Buddhdev
Modified: 2009-06-27 11:45 EDT (History)
9 users (show)

See Also:
Fixed In Version: avahi-0.6.16-2.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-07 10:48:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Anand Buddhdev 2006-12-11 17:39:57 EST
Description of problem:

dbus-daemon produces the error 'Unknown group "netdev" in message bus configuration file' upon 
startup.

Version-Release number of selected component (if applicable):

avahi-0.6.15-1.fc6

How reproducible:

Always

Steps to Reproduce:
1. Update an FC6 system to avahi 0.6.15-1.fc6
2. Restart messagebus, viz: service messagebus restart
  
Actual results:

An error message is produced, as stated in the description.

Expected results:

No error message should be produced.

Additional info:
Comment 1 Jan-Thomas Czornack 2006-12-12 04:09:53 EST
I can confirm this bug. FC6, latest avahi update.
Comment 2 Bastien Nocera 2006-12-18 12:06:07 EST
*** Bug 219764 has been marked as a duplicate of this bug. ***
Comment 3 Bastien Nocera 2006-12-18 12:07:55 EST
*** Bug 219269 has been marked as a duplicate of this bug. ***
Comment 4 John (J5) Palmieri 2006-12-19 12:41:24 EST
*** Bug 220204 has been marked as a duplicate of this bug. ***
Comment 5 John (J5) Palmieri 2006-12-19 12:45:05 EST
*** Bug 219991 has been marked as a duplicate of this bug. ***
Comment 6 John (J5) Palmieri 2006-12-19 13:03:48 EST
I can't find the bug I reassigned to avahi which describes the issue here. 
Basicly avahi's D-Bus security policy has a debianism which appeared in the
latest upstream tarballs.  The netdev user is part of debians way of restricting
user access.  In the future we will most likely use PolicyKit but for now
console user and root access seem the way to go.
Comment 7 Martin Bacovsky 2007-01-07 10:48:38 EST
This bug should be fixed in avahi-0.6.16.
Comment 8 Torsten Rausche 2007-01-08 07:42:01 EST
An update to avahi-0.6.16-1.fc6 does not seem to fix it for me.
Comment 9 Jérôme Benoit 2007-01-16 10:33:11 EST
Latest update do not fix it for me too, only happens on my x86_64 box. My two
x86 do not seems do be "affected" anymore.

Thks
Comment 10 Martin Bacovsky 2007-01-16 11:08:49 EST
Ok, now that really should be fixed (avahi-0.6.16-2.fc6). If you still have
troubles, let me know.
Comment 11 Michal Jaegermann 2007-01-17 16:11:35 EST
What about bug 218140, which is really the same bug as this one but
for "devel", and still lingers as NEW and avahi there still not fixed?
Comment 12 Martin Bacovsky 2007-01-18 04:49:10 EST
I know about that bug. I hope I will have a little time in the next few days to
fix that along with upgrade to upstream 0.6.16.
Comment 13 Martin Bacovsky 2007-01-18 11:14:47 EST
*** Bug 222790 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.