Bug 219307 - Black borders/etc. on Thinkpad X60
Black borders/etc. on Thinkpad X60
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
: 221712 (view as bug list)
Depends On:
Blocks: FC7Blocker
  Show dependency treegraph
 
Reported: 2006-12-12 10:40 EST by Tom London
Modified: 2007-11-30 17:11 EST (History)
6 users (show)

See Also:
Fixed In Version: mesa-6.5.2-4.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-29 11:52:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot w/ black borders (79.24 KB, image/png)
2006-12-13 09:34 EST, Tom London
no flags Details

  None (edit)
Description Tom London 2006-12-12 10:40:07 EST
Description of problem:
This version of mesa botches display on Thinkpad X60 running gnome/compiz:
Windows have solid black borders serveral mm thick, and the screen slowly
degrades by 'whitening' (e.g., portions of screen go all white and then nothing
is displayed there).

Reverting to 6.5.1-8.fc6 'fixes'.

[Previously reported on fedora-devel list; didn't want this to get lost.

Here is lspci output:
00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS/940GML and
945GT Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile
945GM/GMS/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/940GML
Express Integrated Graphics Controller (rev 03)
]

Version-Release number of selected component (if applicable):
mesa-*-6.5.2-2.fc7.i386

How reproducible:
Every time

Steps to Reproduce:
1. install
2. reboot
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tom London 2006-12-13 09:34:02 EST
Created attachment 143518 [details]
Screenshot w/ black borders
Comment 2 Tom London 2006-12-13 09:34:43 EST
Uhhhh.... today's rawhide updates messed things up:

mesa*-6.5.2-3.fc7.i386 packages removed the black border and things looked OK at
startup, but the screen quickly 'whited out': I got white rectangles on the
background when I resized windows, random white boxes on screen, eventually the
entire screen, including panels were white.

Reverting to mesa*-6.5.1-8.fc6.i386 made the white go away, but now I can't get
rid of the black borders....

Panel seems OK, no whitening of screen, but cludgey black borders.....

I attach cropped screen shot.  (Sorry, attachment got there first....)
Comment 3 Tom London 2006-12-13 09:41:37 EST
Reverting to xorg-x11-server-Xorg-1.1.1-54 with older mesa, logging off, and
logging back in seems to restore.

Does this make sense? (Or have I botched something.....)
Comment 4 Daniel Malmgren 2006-12-19 08:03:51 EST
I'd just like to confirm this one. I'm also on a 945GM laptop.
Comment 5 Tom London 2006-12-20 10:28:10 EST
Same behavior with mesa-*-6.5.2-4.fc7.i386.rpm and
xorg-x11-server-Xorg-1.1.1-56.fc7.

Continues to work with mesa*-6.5.1-8.fc6.i386 and xorg-x11-server-Xorg-1.1.1-54
Comment 6 Tom London 2007-01-03 14:25:37 EST
Not sure its helpful, but I'm running with i810 driver, as the intel driver is
not working for me.
Comment 7 Daniel Malmgren 2007-01-04 09:30:26 EST
No, I'm using intel driver, so that can't be it.
Comment 8 Jukka Ketelaars 2007-01-04 11:22:29 EST
I'm having the same problem (but with white borders) with the xorg ati driver,
so I suppose the problem lies elsewhere.
Comment 9 Ralf Ertzinger 2007-01-04 11:45:28 EST
See https://bugs.freedesktop.org/show_bug.cgi?id=9456

X60s here, intel driver
Comment 10 Ralf Ertzinger 2007-01-04 12:44:56 EST
Oh, and is there a way to make this bug more findable? Having it turn up when
looking for "compiz" and "white" would be nice.
Comment 11 Daniel Malmgren 2007-01-08 06:15:08 EST
Now this is strange. I've been seing the strange black borders with Mesa 6.5.1,
and I've been unable to use 6.5.2 at all because of the whiteness Tom reports. I
upgraded to 6.5.2 today to try out some of the stuff suggested in #221712 to get
rid of the white stuff. I fiddled around for a while with changing the "advanced
beryl settings" for binding and rendering from automatic to XGL back and forth.
Since I still couldn't get it to work I once again downgraded to 6.5.1, and now
suddenly it all works! No black borders, nothing gets strangely white. Strange!

(I know. This doesn't solve much since 6.5.2 is still unusable. But at least now
I've got a pretty looking desktop again using 6.5.1 ;-)
Comment 12 Frank de Lange 2007-01-08 07:02:26 EST
*** Bug 221712 has been marked as a duplicate of this bug. ***
Comment 13 Daniel Malmgren 2007-01-09 02:17:39 EST
Hmmm... Found out what happened in the case I describe in comment #11. When
upgrading libGLU and downgrading it again the symlinks got busted. It seems that
if the symlink /usr/lib64/libGLU.so.1 points at something that doesn't exist
there will be no black borders. Since I discovered some nasty side effects I had
to fix the symlink. Now my desktop isn't pretty looking anymore :-/
Comment 14 Daniel Malmgren 2007-01-09 02:44:38 EST
Sorry for the flooding here, but I just found the explanation to the black
borders. It's a "result of building xorg-server against  another mesa-version
than the one installed" (https://bugs.freedesktop.org/show_bug.cgi?id=9233). So
I guess the problem here is the "whitening" that prevents us from using mesa 6.5.2.

Upstreams bug for this: https://bugs.freedesktop.org/show_bug.cgi?id=9456

Would this be fixed just by recompiling some rpm's? I'll try that myself when I
get time...
Comment 15 Tom London 2007-01-10 10:01:05 EST
Tried again today with today's rawhide (xorg-x11-server-Xorg-1.1.1-57.fc7).

Here are results:
1. Just updating xorg-xll-server-Xorg, but keeping mesa packages at 6.5.1-8.fc6
produces 'black borders'.
2. Reverting xorg-x11-server-Xorg fixes.
3. Updating xorg-x11-server-Xorg and mesa packages to 6.5.2-4.fc7 produces
'whitening' describes in #14 and https://bugs.freedesktop.org/show_bug.cgi?id=9456.
4. Reverting xorg-x11-server-Xorg to 1.1.1-54.fc7 and mesa to 6.5.1-8.fc6 fixes.

https://bugs.freedesktop.org/show_bug.cgi?id=9456 seems to indicate some subtle
'API/protocol mismatch' issues with various git (and other) branches.

That plausible?
Comment 16 Tom London 2007-01-24 10:24:13 EST
Updating to xorg-x11-server-Xorg-1.2.0-1.fc7 and updating mesa packages to
-6.5.2-4.fc7 makes this 'work for me' with i810 driver (Thinkpad X60): no more
black borders and no more whitening out.

[Only updating to xorg-x11-server-Xorg-1.2.0-1.fc7 (with 6.5.1-8.fc6 mesa
packages) produces black borders.]
Comment 17 Daniel Malmgren 2007-01-25 02:43:45 EST
(In reply to comment #16)
> Updating to xorg-x11-server-Xorg-1.2.0-1.fc7 and updating mesa packages to
> -6.5.2-4.fc7 makes this 'work for me' with i810 driver (Thinkpad X60): no more
> black borders and no more whitening out.

Confirmed. This works now.
Comment 18 Frank de Lange 2007-01-28 07:56:35 EST
Confirmed again, works on Radeon M6 LY

Note You need to log in before you can comment on or make changes to this bug.