Bug 221712 - White screen issues with compiz/beryl and mesa 6.5.2
White screen issues with compiz/beryl and mesa 6.5.2
Status: CLOSED DUPLICATE of bug 219307
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
Depends On:
  Show dependency treegraph
Reported: 2007-01-06 10:31 EST by Frank de Lange
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-01-08 07:02:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 9456 None None None Never

  None (edit)
Description Frank de Lange 2007-01-06 10:31:50 EST
Description of problem:
As the freedesktop.org bug report (see quoted url) gives a good description I'll
copy/paste part of it here:

"With these updates, (compiz and) beryl redraws parts of the screen as white
parts. Some, bu not all, shadows appear as white borders and some parts of the
screen are covered in white squares."

Running beryl-xgl (which is statically linked with libGL) works as expected.

Replacing /usr/lib/libGL.so.1.2 and the active dri file (from
mesa-libGL-6.5.2-4.fc7) with the copies from mesa-libGL-6.5.1-8.fc6.i386.rpm
makes compiz and beryl work as expected.

Version-Release number of selected component (if applicable):

How reproducible:
Always, just start compiz or beryl with the mentioned mesa libGL version.

Steps to Reproduce:
1. update system to latest mesa-libGL
2. start compositing manager (compiz or beryl)
3. white-out...
Actual results:
White where no white should be

Expected results:
A useable desktop displaying more than just white squares, white borders, a
white background, etc...

Additional info:
Using the radeon driver (/usr/lib/xorg/modules/drivers/radeon_drv.so
(xorg-x11-drv-ati-6.6.3-1.fc7) and /usr/lib/dri/radeon_dri.so (see description))
on Mobility M6 LY
Comment 1 Daniel Malmgren 2007-01-08 06:16:47 EST
I'm not totally sure, but I think this bug should be marked a dupe of #219307.
Comment 2 Frank de Lange 2007-01-08 07:02:14 EST
Agree, it seems like I missed this report when I filed my bug.

*** This bug has been marked as a duplicate of 219307 ***

Note You need to log in before you can comment on or make changes to this bug.