Bug 219309 - No networking: IRQ nrs appear truncated
No networking: IRQ nrs appear truncated
Status: CLOSED DUPLICATE of bug 219277
Product: Fedora
Classification: Fedora
Component: kernel-xen (Show other bugs)
6
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Herbert Xu
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-12 10:46 EST by Calvin Webster
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-15 00:42:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg from kernel 2.6.18-1.2857.6.1.fc6.jwltest.15 (22.73 KB, text/plain)
2006-12-14 10:57 EST, Calvin Webster
no flags Details
dmesg from kernel 2.6.18-1.2857.4.2.fc6.0.2.sctxen (30.79 KB, text/plain)
2006-12-14 10:59 EST, Calvin Webster
no flags Details

  None (edit)
Description Calvin Webster 2006-12-12 10:46:47 EST
Description of problem:

Although network config appears normal, cannot reach any host except local
machine ip addr.

Version-Release number of selected component (if applicable):

kernel: 2.6.18-1.2857.4.2.fc6.0.2.sctxen

How reproducible: always


Steps to Reproduce:
1. Boot into xen kernel 2.6.18-1.2857.4.2.fc6.0.2.sctxen
2. Attempt to ping local gateway or any other host
3.
  
Actual results:

Ping unsuccessful to any host except local machine ip address
"dmesg" reports truncated IRQ numbers compared to non-xen kernel
"dmesg" reports 251 instances of "late interrupt" on eth0

Expected results:

Successful ping to any reachable network host
"dmesg" report normal IRQ numbers
No "late interrupt" messages

Additional info:

The IRQ assignments don't look right to me. Here's how they differ in
"dmesg" between non-Xen (<) and Xen (>) kernel boots. At a glance, it looks like
the IRQ numbers are being truncated.

191c163
< ACPI: PCI Interrupt 0000:00:01.0[A] -> GSI 16 (level, low) -> IRQ 169
---
> ACPI: PCI Interrupt 0000:00:01.0[A] -> GSI 16 (level, low) -> IRQ 16
193c165
< ACPI: PCI Interrupt 0000:00:1c.0[A] -> GSI 16 (level, low) -> IRQ 169
---
> ACPI: PCI Interrupt 0000:00:1c.0[A] -> GSI 16 (level, low) -> IRQ 16
195c167
< ACPI: PCI Interrupt 0000:00:1c.1[B] -> GSI 17 (level, low) -> IRQ 177
---
> ACPI: PCI Interrupt 0000:00:1c.1[B] -> GSI 17 (level, low) -> IRQ 17
197c169
< ACPI: PCI Interrupt 0000:00:1c.3[D] -> GSI 19 (level, low) -> IRQ 185
---
> ACPI: PCI Interrupt 0000:00:1c.3[D] -> GSI 19 (level, low) -> IRQ 18


Also, there are over 250 of these messages in "dmesg":

eth0: late interrupt.

Here are the last several lines from "dmesg":

eth0: late interrupt.
device vif0.0 entered promiscuous mode
xenbr0: port 1(vif0.0) entering learning state
xenbr0: topology change detected, propagating
xenbr0: port 1(vif0.0) entering forwarding state
device peth0 entered promiscuous mode
Comment 1 Herbert Xu 2006-12-14 00:26:56 EST
The interrupt numbers haven't been truncated.  The IRQs you get in dom0 are
actually virtualised by the hypervisor.

Please attach the complete dmesg as well as a dmesg from a baremetal kernel. 
Thanks.
Comment 2 Calvin Webster 2006-12-14 10:57:09 EST
Created attachment 143645 [details]
dmesg from kernel 2.6.18-1.2857.6.1.fc6.jwltest.15

As requested, dmesg content from baremetal kernel
Comment 3 Calvin Webster 2006-12-14 10:59:31 EST
Created attachment 143647 [details]
dmesg from kernel 2.6.18-1.2857.4.2.fc6.0.2.sctxen

As requested, dmesg from xen kernel
Comment 4 Herbert Xu 2006-12-15 00:42:42 EST

*** This bug has been marked as a duplicate of 219277 ***

Note You need to log in before you can comment on or make changes to this bug.