Bug 219277 - b44: eth0: late interrrupt
b44: eth0: late interrrupt
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel-xen (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Eduardo Habkost
Brian Brock
: Patch
: 219309 (view as bug list)
Depends On:
Blocks: 216472
  Show dependency treegraph
 
Reported: 2006-12-12 07:46 EST by Karsten Hopp
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-03 06:43:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
[LINUX] dma: Use swiotlb mask for coherent mappings too (1.82 KB, patch)
2006-12-20 00:23 EST, Herbert Xu
no flags Details | Diff

  None (edit)
Description Karsten Hopp 2006-12-12 07:46:30 EST
Description of problem:
This is a followup bugreport related to the b44 problems reported in bug 
208242 and SCT's kernel from 
http://people.redhat.com/sct/packages/kernel/kernel-xen-2.6.18-1.2857.4.2.fc6.0.2.sct/

The module now loads fine:
b44.c:v1.01 (Jun 16, 2006)
ACPI: PCI Interrupt 0000:03:00.0[A] -> GSI 17 (level, low) -> IRQ 17
eth0: Broadcom 4400 10/100BaseT Ethernet 00:xx:xx:xx:xx:xx

But when I try to get a DHCP address with 'ifup eth0', I get lots of these 
messages in dmesg:
eth0: late interrupt.
eth0: late interrupt.
eth0: late interrupt.
eth0: late interrupt.

DHCP doesn't work, there's no address assigned
Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 3 Herbert Xu 2006-12-15 00:42:55 EST
*** Bug 219309 has been marked as a duplicate of this bug. ***
Comment 4 Herbert Xu 2006-12-15 00:48:57 EST
Karsten, any chance of you getting me remote access to a machine with the b44
chipset plus one other working NIC? If you can't get another NIC then serial
console access would be OK too.  Thanks.
Comment 5 Karsten Hopp 2006-12-15 05:38:55 EST
Sorry, Herbert, but that's my own Dell 9400 Laptop with lots of private data on
it. I can't give you access, but if there's anything I can test, I'll give it a
try. 
Comment 6 Calvin Webster 2006-12-15 12:46:55 EST
I may be able to setup remote access on this machine for you when I return to
North Carolina this weekend. I'm in TX right now, using a shared dynamic IP
address. Would you be connecting from a Red Hat facility (i.e. Red Hat HQ in
Raleigh)? I'll need some assurance that your side of the connection is
reasonably secure. If so, I can temporarily open a ssh port on my firewall -
login/passwd to be given verbally over the phone.

Since I can't get any networking going while running the Xen kernel, you will
only be able to work on the system while running the baremetal kernel. This is a
Dell Inspiron E1705 (same exact computer as the 9400 - just branded for consumer
market)

In the meantime, would you like some "sysreports"? I've generated two, one each
for xen and non-xen kernels. Commands used:

Non-Xen:  sysreport -dmidecode
Xen:      sysreport -norpm -dmidecode

## I figured you'd only need the rpm info once.
Comment 7 Herbert Xu 2006-12-17 22:34:50 EST
Thanks Calvin.  I work remotely so I won't be coming from a Red Hat address. 
Although I do use a static IP at home so I can give that to you for firewalling
purposes.

As to the actual machine, I do need to have Xen running on it so if you could
setup a serial console for it then it would work.

Otherwise what I need is more information about where exactly the first failure
is.  So first of all what does ifconfig show after has started? If the interface
shows as up, then we'll need to sprinkle some printks in the transmit/receive
routines.  Otherwise we need to debug the b44_open function.

Thanks.
Comment 8 Calvin Webster 2006-12-18 12:29:32 EST
I'll probably be working late today at a customer site getting information for a
Red Hat Support ticket on the NFS/kernel spinlock bug. My home office computer
lab is where I'll be setting up your connection, so it'll be late tonight before
it's done.

I'm thinking I'll setup a SSH account on my DMZ machine and configure minicom to
connect to the laptop's console port. That way you can stay connected during
reboots and get the early boot messages as they occur.

After reading a short bio on you I'm confident you will take all necessary
precautions on your end. I would prefer to keep my IP address private so I'll
send it to your email address.

Thank you very much for your time!!
Comment 9 Herbert Xu 2006-12-20 00:23:50 EST
Created attachment 144073 [details]
[LINUX] dma: Use swiotlb mask for coherent mappings too

Thanks to Calvin I'ved tracked down the issue to the fact that coherent DMA
mappings are still 31 bits wide rather than 30 which we've changed for
streaming mappings.

This is the patch that I submitted upstream.
Comment 10 Herbert Xu 2007-01-23 01:59:16 EST
Juan, when you get a chance could you please add the above patch to FC6? Thanks.
Comment 11 Calvin Webster 2007-01-23 18:44:53 EST
Just updated to kernel-xen-2.6.18-1.2869.fc6, but I'm still getting errors from
the b44 module:

dmesg:
---------------------------------------------------------
b44.c:v1.01 (Jun 16, 2006)
ACPI: PCI Interrupt 0000:03:00.0[A] -> GSI 17 (level, low) -> IRQ 17
b44 0000:03:00.0: No usable DMA configuration, aborting.
ACPI: PCI interrupt for device 0000:03:00.0 disabled
b44: probe of 0000:03:00.0 failed with error -5
---------------------------------------------------------

Herbert,

I can make my laptop available for testing again if needed. Please let me know
ahead of time.

Thanks!

--Cal
Comment 12 Herbert Xu 2007-01-23 19:53:19 EST
Sorry Cal, the fix just hasn't made it into FC6 yet.  Hopefully it will soon.
Comment 13 Eduardo Habkost 2007-07-02 12:00:54 EDT
I have noticed that the fix was included on FC6 since release 1.2941. Could 
you check if the problem is fixed for you, on kernel 2.6.20-1.2941 or later?

Sorry for the long delay without any reply on this bug.
Comment 14 Calvin Webster 2007-07-02 12:32:45 EDT
Yes, it started working about 2 updates ago for me. Thanks!

Note You need to log in before you can comment on or make changes to this bug.