Bug 21960 - RedHat reported an internal error while installation in an partionless installation over an Windows NT workstaion with FAT filesystem
Summary: RedHat reported an internal error while installation in an partionless instal...
Status: CLOSED DUPLICATE of bug 19523
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Erik Troan
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-08 20:41 UTC by ashish nanjiani
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-11 16:35:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description ashish nanjiani 2000-12-08 20:41:49 UTC
Here's the dump of the error

Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File 
"/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in run
    rc = apply (step[1](), step[2])
  File 
"/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 507, in __call__
    if todo.doInstall ():
  File 
"/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1466, in doInstall
    self.fstab.makeFilesystems ()
  File 
"/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 664, in makeFilesystems
    isys.umount("/mnt/loophost")
  File 
"/usr/lib/anaconda/isys.py", line 116, in umount
    mountCount[what] = mountCount - 1
TypeError: bad operand type(s) for -

Local 
variables in innermost frame:
what: /mnt/loophost
removeDir: 1

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>


Hardware

Intel 
Installation: Partiotionless
OS: WINDOWS NT WORKSTATION
Filesytem: FAT
Processor: Pentium
Memory: 32MB

Comment 1 Michael Fulbright 2000-12-08 20:47:45 UTC
This looks like a dupe of bug 19523.

It would help greatly if you could give step by step instructions on how to
reproduce this problem.

Comment 2 ashish nanjiani 2000-12-08 22:27:23 UTC
step by step process to create the error.

scenario: Windows NT workstation 4.00.1381
               FAT filesystem with 1.4G free space.- single partition
               RAM = 32MB

1) Boot throught Linux RedHat CD 7.0
2) Select Custom installation.
3) Select disk druid as the partiion utility
4) Edit the single partition shown , and select the mount point as / . ( RedHat give some warnings about penalty for not using Linux-Native partitions )
5) Since memory is less then 32, RedHat installations prompts to create swap partion (filesystem) immediatly to proceed further
6) Say yes
7) RedHat prompts for package selection.
8) RedHat create loopback filesystem
9) Does formating of / file system
10) Reads package information and gives the error reported.


Comment 3 Brock Organ 2000-12-18 21:24:35 UTC
this problem occurs when a partitionless install requires a package from the 2nd
CD ...

Comment 4 Michael Fulbright 2000-12-19 16:31:46 UTC
Assigning to a developer.

Comment 5 Michael Fulbright 2001-01-11 16:35:46 UTC

*** This bug has been marked as a duplicate of 19523 ***


Note You need to log in before you can comment on or make changes to this bug.