Bug 219632 - Radeon and AIGLX freezes
Radeon and AIGLX freezes
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Airlie
:
: 242151 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-14 10:38 EST by Ed Marshall
Modified: 2009-03-16 18:45 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-02 16:48:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (1.17 KB, text/plain)
2006-12-14 10:38 EST, Ed Marshall
no flags Details
Xorg.0.log (44.17 KB, text/plain)
2006-12-14 10:39 EST, Ed Marshall
no flags Details
lspci -vvv output (15.95 KB, text/plain)
2006-12-14 10:39 EST, Ed Marshall
no flags Details
lspci -vvv output (10.63 KB, text/plain)
2007-01-09 17:53 EST, Christopher Brown
no flags Details
xorg.conf file (1.09 KB, text/plain)
2007-01-09 17:54 EST, Christopher Brown
no flags Details
Log from aiglx enabled sessions (43.30 KB, text/plain)
2007-01-09 17:55 EST, Christopher Brown
no flags Details
Requested file: xorg.conf (808 bytes, text/plain)
2008-01-02 06:39 EST, Daniel Rey
no flags Details
Requested file: Xorg.0.log (54.58 KB, text/plain)
2008-01-02 06:43 EST, Daniel Rey
no flags Details
Requested file: Xorg.0.log (57.24 KB, text/plain)
2008-01-02 06:44 EST, Daniel Rey
no flags Details

  None (edit)
Description Ed Marshall 2006-12-14 10:38:14 EST
Description of problem:
After enabling "desktop effects", display experiences random lockups during
display of said effects, and occasionally compiz will fail to start upon login.

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.6.3-1.fc6

How reproducible:
Just about every time.

Steps to Reproduce:
1. Buy a Lenovo ThinkPad T43p (http://www.thinkwiki.org/wiki/Category:T43p for
hardware specifications, I have the 15" 1600x1200 TFT).
2. Enable desktop effects using the xorg radeon driver.
3. Use desktop for a while, possibly log out and back in again.

Actual results:
On login, compiz will *sometimes* fail to start; disabling and then re-enabling
desktop effects fixes this. However, after several minutes to several hours of
use, the desktop will eventually hang (always in the middle of displaying a
fade, wobble, or other effect).

Expected results:
The same stability I got out of the non-AIGLX desktop. ;-) This was actually a
very stable setup prior to trying out AIGLX, with both the radeon driver and
with fglrx.

Additional info:
Here's the lspci info for my video card (I'll attach the full lspci output in a
moment, along with the xorg.conf I'm using and a relevant Xorg.0.log):

01:00.0 VGA compatible controller: ATI Technologies Inc M24 1T [FireGL M24 GL]
(rev 80) (prog-if 00 [VGA])
        Subsystem: IBM Unknown device 0570
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR+ FastB2B-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort-
<MAbort+ >SERR- <PERR-
        Latency: 0, Cache Line Size: 32 bytes
        Interrupt: pin A routed to IRQ 169
        Region 0: Memory at c0000000 (32-bit, prefetchable) [size=128M]
        Region 1: I/O ports at 3000 [size=256]
        Region 2: Memory at b0100000 (32-bit, non-prefetchable) [size=64K]
        [virtual] Expansion ROM at b0120000 [disabled] [size=128K]
        Capabilities: [50] Power Management version 2
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [58] Express Endpoint IRQ 0
                Device: Supported: MaxPayload 128 bytes, PhantFunc 0, ExtTag+
                Device: Latency L0s <256ns, L1 <4us
                Device: AtnBtn- AtnInd- PwrInd-
                Device: Errors: Correctable- Non-Fatal- Fatal- Unsupported-
                Device: RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop+
                Device: MaxPayload 128 bytes, MaxReadReq 128 bytes
                Link: Supported Speed 2.5Gb/s, Width x16, ASPM L0s L1, Port 0
                Link: Latency L0s <256ns, L1 <2us
                Link: ASPM L1 Enabled RCB 64 bytes CommClk+ ExtSynch-
                Link: Speed 2.5Gb/s, Width x16
        Capabilities: [80] Message Signalled Interrupts: 64bit+ Queue=0/0 Enable-
                Address: 0000000000000000  Data: 0000
        Capabilities: [100] Advanced Error Reporting
Comment 1 Ed Marshall 2006-12-14 10:38:15 EST
Created attachment 143639 [details]
xorg.conf
Comment 2 Ed Marshall 2006-12-14 10:39:14 EST
Created attachment 143640 [details]
Xorg.0.log

Log from a typical session that freezes.
Comment 3 Ed Marshall 2006-12-14 10:39:33 EST
Created attachment 143641 [details]
lspci -vvv output
Comment 4 Ed Marshall 2006-12-14 10:40:31 EST
Also note that the system itself does not freeze; only the display. When this
happens, I'm able to ssh back into the laptop from another machine and
"gracefully" shut things down, but the screen never returns to normal until the
system is rebooted.
Comment 5 Christopher Brown 2007-01-09 17:53:46 EST
Created attachment 145205 [details]
lspci -vvv output
Comment 6 Christopher Brown 2007-01-09 17:54:31 EST
Created attachment 145206 [details]
xorg.conf file
Comment 7 Christopher Brown 2007-01-09 17:55:07 EST
Created attachment 145207 [details]
Log from aiglx enabled sessions
Comment 8 Christopher Brown 2007-01-09 17:57:47 EST
I see this also. This on a Thinkpad T42. See above attachments. Workaround is
obviously to disable desktop effects however given that it took me a while to
find the (probable) cause I would ask this to be re-prioritised upwards as there
is likely to be a number of folks who are banging their heads into walls/screens
on this one.
Comment 9 Christopher Brown 2007-01-23 16:00:01 EST
Edward,

Could you please test with the latest flash plugin (ie. 9 final) as I believe
this to be the source of our problems.

Regards
Chris
Comment 10 Angelo Lisco 2007-10-05 16:18:19 EDT
Hi guys...sadly, same problem in ubuntu:
https://bugs.launchpad.net/fedora/+source/xserver-xorg-video-ati/+bug/108527
Comment 11 Matěj Cepl 2007-10-05 17:55:02 EDT
*** Bug 242151 has been marked as a duplicate of this bug. ***
Comment 12 Matěj Cepl 2007-12-10 04:22:24 EST
Fedora Core 6 is no longer supported, could you please reproduce this with the
updated version of the currently supported distribution (Fedora 7, 8, or
Rawhide)? If this issue turns out to still be reproducible, please let us know
in this bug report. If after a month's time we have not heard back from you, we
will have to close this bug as CANTFIX.

Setting status to NEEDINFO, and awaiting information from the reporter.

[This is mass-filed message to all open Fedora Core 6 bugs related to Xorg or
Gecko. If you see any other reason, why this bug shouldn't be closed, please,
comment on it here.]
Comment 13 Daniel Rey 2007-12-20 14:13:38 EST
I can confirm the same issue with both Fedora 7 and 8 on a HP Compaq nx8220
laptop. The video card is:
01:00.0 VGA compatible controller: ATI Technologies Inc M24 1P [Radeon Mobility
X600]

Enabling desktop effects causes freezes, with them disabled I have no problems
at all...
Comment 14 Matěj Cepl 2007-12-20 17:26:48 EST
Could we get please updated X server config file (/etc/X11/xorg.conf) and X
server log file (/var/log/Xorg.*.log) attached to the bug report as individual
uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 15 Daniel Rey 2008-01-02 06:39:56 EST
Created attachment 290647 [details]
Requested file: xorg.conf
Comment 16 Daniel Rey 2008-01-02 06:43:26 EST
Created attachment 290648 [details]
Requested file: Xorg.0.log

Xorg.o.log copied after the freeze, X started with the xorg.conf previously
attached.
Comment 17 Daniel Rey 2008-01-02 06:44:39 EST
Created attachment 290649 [details]
Requested file: Xorg.0.log

Xorg.0.log copied after the freeze, X started without any xorg.conf file.
Comment 18 Daniel Rey 2008-01-02 06:55:01 EST
For these tests I enabled desktop-effects and rebooted to make sure AIGLX and
compiz were there from the start.

The first time the screen froze after about 20 minutes of use (the test with the
xorg.conf file in place, as it usually is). The second time (without the
xorg.conf file) it froze after about 5 minutes of use. Both times the screen
froze completely except for the mouse pointer which still moves but can't click
anywhere. The keyboard freezes also.

Logging to the laptop from another machine via ssh works fine, this is how I
copied the logs. Here is some extra info taken after the second freeze:

[root@dragon ~]# uptime 
 21:03:10 up 15 min,  3 users,  load average: 0.00, 0.10, 0.17
[root@dragon ~]# free
             total       used       free     shared    buffers     cached
Mem:       1034820     714744     320076          0      36076     301340
-/+ buffers/cache:     377328     657492
Swap:      1048568          0    1048568
[root@dragon ~]# vmstat 
procs -----------memory---------- ---swap-- -----io---- --system-- -----cpu------
 r  b   swpd   free   buff  cache   si   so    bi    bo   in   cs us sy id wa st
 0  0      0 320032  36080 301352    0    0   355    32  310  893  9  3 80  8  0

[root@dragon ~]# ps ax | grep comp
 2867 ?        S      0:02 compiz --sm-client-id default1 glib gconf
 3799 pts/3    S+     0:00 grep comp
[root@dragon ~]# strace -p 2867
Process 2867 attached - interrupt to quit
select(5, [4], [], NULL, NULL

Hope it helps...
Comment 19 Samuel Sieb 2008-04-25 12:39:57 EDT
I'm using latest F8 and I tend to get a lot more time before it freezes.  I do
have some details though.  The problem appears to be in the kernel, or the
interaction between the kernel and the X server.

kernel-2.6.24.4-64.fc8
compiz-0.6.2-3.fc8
xorg-x11-drv-ati-6.8.0-4.fc8

Doing strace on "chvt 1" from an ssh connection hangs at the following point:
open("/dev/tty0", O_RDWR)               = 3
ioctl(3, KDGKBTYPE, 0xbfd23c77)         = 0
ioctl(3, VIDIOC_G_COMP or VT_ACTIVATE, 0x1) = 0
ioctl(3, VIDIOC_S_COMP or VT_WAITACTIVE <unfinished ...>

Doing strace on X gives endlessly repeating:
ioctl(9, 0x40046457, 0xa3fdff4)         = -1 EINTR (Interrupted system call)
--- SIGALRM (Alarm clock) @ 0 (0) ---
sigreturn()                             = ? (mask now [])
ioctl(9, 0x40046457, 0xa3fdff4)         = -1 EINTR (Interrupted system call)
--- SIGALRM (Alarm clock) @ 0 (0) ---
sigreturn()                             = ? (mask now [])
ioctl(9, 0x40046457 <unfinished ...>

A gdb backtrace on X gives:
#0  0x00110402 in __kernel_vsyscall ()
#1  0x00609c29 in ioctl () from /lib/libc.so.6
#2  0x04ce549b in drmCommandWrite () from /usr/lib/libdrm.so.2
#3  0x00af833e in ?? () from /usr/lib/dri/r300_dri.so
#4  0x00b269b8 in ?? () from /usr/lib/dri/r300_dri.so
#5  0x0018ab85 in ?? () from /usr/lib/xorg/modules/extensions//libglx.so
#6  0x0018a09a in ?? () from /usr/lib/xorg/modules/extensions//libglx.so
#7  0x0018eb16 in ?? () from /usr/lib/xorg/modules/extensions//libglx.so
#8  0x08150d3e in ?? ()
#9  0x0808881a in Dispatch ()
#10 0x0807054a in main ()

Comment 20 Samuel Sieb 2008-04-29 14:59:32 EDT
I installed debuginfo packages and this is the result:

#0  0x00110402 in __kernel_vsyscall ()
#1  0x00609c29 in ioctl () from /lib/libc.so.6
#2  0x04ce549b in drmCommandWrite (fd=9, drmCommandIndex=23, data=0xa3aa77c, 
    size=4) at xf86drm.c:2227
#3  0x00af833e in radeonWaitIrq (radeon=0xa3aa728) at radeon_ioctl.c:116
#4  0x00b269b8 in _mesa_Finish () at main/context.c:1676
#5  0x0018ab85 in __glXDisp_CopySubBufferMESA (cl=0xa29d098, 
    pc=0xc08f1f8 "\201\020\b") at glxcmds.c:1679
#6  0x0018a09a in __glXDisp_VendorPrivate (cl=0xa29d098, 
    pc=0xc08f1f8 "\201\020\b") at glxcmds.c:2322
#7  0x0018eb16 in __glXDispatch (client=0xa22b040) at glxext.c:561
#8  0x08150d3e in XaceCatchExtProc (client=0xa22b040) at xace.c:299
#9  0x0808881a in Dispatch () at dispatch.c:457
Comment 21 Daniel Rey 2008-05-20 09:04:17 EDT
After a fresh install of Fedora 9 (only kept /home untouched, formatted
everything else) I am still getting exactly the same behavior. A few minutes
after enabling desktop effects the screen froze.
Comment 22 Samuel Sieb 2008-06-19 11:34:27 EDT
I just reproduced this on F9 as well.  It took a little longer than a few
minutes, but it did eventually happen.  I've noticed that it always seems to
happen with a fading effect.  In this last case, I was using the Applications
menu and it froze while fading in one of the submenus.  Before it has happened
while changing the volume, the volume display is semi-transparent or fades.

My laptop integrated video card is:
01:00.0 VGA compatible controller: ATI Technologies Inc M22 [Mobility Radeon X300]
Comment 23 Matěj Cepl 2008-10-08 12:21:16 EDT
Does anybody see this on Fedora 9 and lower? (Rawhide doesn't count)
Comment 24 Samuel Sieb 2008-10-08 12:41:50 EDT
Yes, I said that in comment #22.  I tested it again recently and it still happens.
Comment 25 Daniel Rey 2008-10-08 13:12:46 EDT
Yes, I also see this in Fedora 9 and saw it before in F8 and F7. I tried several other times since I posted comment #21, after kernel or X.org upgrades with the same behaviour. I haven't tried again after the latest upgrades though. I will try as soon as I can and post the results.
Comment 26 Samuel Sieb 2008-10-08 14:01:54 EDT
A further note is that it only happens on my laptop with the integrated video.  I have two desktop computers with video cards that I've run compiz on with no problems.  I do have a couple of desktop computers at home with "RS690 [Radeon X1200 Series]" integrated video that I could test on if that would help.  But I'm guessing from the reports in this bug that it's only the X300 with the problem.
Comment 27 Daniel Rey 2008-10-08 15:14:50 EDT
Mine is a X600 and has the same problem. My desktop at home has an nvidia card and works fine.
Comment 28 Samuel Sieb 2008-10-14 14:32:23 EDT
A further data point.  One of my desktop systems that doesn't have a problem is an X300 on PCI Express.

01:00.0 VGA compatible controller: ATI Technologies Inc RV370 5B60 [Radeon X300 (PCIE)]
01:00.1 Display controller: ATI Technologies Inc RV370 [Radeon X300SE]

I don't know why it has two entries.
Comment 29 Jóhann B. Guðmundsson 2008-12-01 06:02:40 EST
There have been bunch of bug fixes

Could you retest with the latest kernel 
( -132 at the time of this writing )

You can get the latest kernel build here
http://koji.fedoraproject.org/koji/buildinfo?buildID=72270 

And with the latest xorg-x11-drv-ati. 
( -60 at the time of this writing )

You can get the latest xorg-x11-drv-ati build here
http://koji.fedoraproject.org/koji/packageinfo?packageID=95

And report back if it either improves or fixes this issue..

Thanks.
Comment 30 François Cami 2009-03-02 16:48:26 EST
The information we've requested above is required in order
to review this problem report further and diagnose or fix the
issue if it is still present.  Since it has been thirty days or
more since we first requested additional information, we're assuming
the problem is either no longer present in the current Fedora release, or
that there is no longer any interest in tracking the problem.

Setting status to "CLOSED: INSUFFICIENT_DATA".  If you still
experience this problem after updating to our latest Fedora
release and can provide the information previously requested,
please feel free to reopen the bug report.

Thank you in advance.
Comment 31 Samuel Sieb 2009-03-05 15:03:53 EST
Now that bug #473307 is fixed, I can turn on desktop effects again and see if this bug is fixed as well.
Comment 32 Samuel Sieb 2009-03-16 18:45:17 EDT
I've had no hangs so far, so it appears to be fixed.

Note You need to log in before you can comment on or make changes to this bug.