Bug 242151 - Compiz enable on F7 with Radeon videocard results in random hangs
Compiz enable on F7 with Radeon videocard results in random hangs
Status: CLOSED DUPLICATE of bug 219632
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
7
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-01 17:09 EDT by Nicolas A. Corrarello
Modified: 2007-11-30 17:12 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-05 17:55:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Sysreport (328.59 KB, application/x-bzip)
2007-06-01 17:21 EDT, Nicolas A. Corrarello
no flags Details
reporter's /etc/X11/xorg.conf from sysreport report (806 bytes, text/plain)
2007-09-11 19:50 EDT, Matěj Cepl
no flags Details
reporter's /var/log/Xorg.0.log from sysreport report (42.38 KB, text/plain)
2007-09-11 19:51 EDT, Matěj Cepl
no flags Details

  None (edit)
Description Nicolas A. Corrarello 2007-06-01 17:09:14 EDT
Description of problem:


Version-Release number of selected component (if applicable):
compiz-0.3.6-8.fc7
Fedora release 7 (Moonshine)

How reproducible:
Very

Steps to Reproduce:
1. Default Install of Fedora on IBM Thinkpad T43 (Or I think, any other with
Radeon X300 as videocard)
2.Enable Compiz
3.You get random hangs of the OS (turns unresponsive, mouse does not move,
cannot switch to virtual console)
  
Actual results:
Random Hangs

Expected results:
Stability

Additional info:
[root@edgar ~]# /sbin/lspci
00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express
Processor to DRAM Controller (rev 03)
00:01.0 PCI bridge: Intel Corporation Mobile 915GM/PM Express PCI Express Root
Port (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI
Express Port 1 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI
Express Port 3 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #3 (rev 03)
00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #4 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB2 EHCI Controller (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev d3)
00:1e.2 Multimedia audio controller: Intel Corporation 82801FB/FBM/FR/FW/FRW
(ICH6 Family) AC'97 Audio Controller (rev 03)
00:1e.3 Modem: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Modem
Controller (rev 03)
00:1f.0 ISA bridge: Intel Corporation 82801FBM (ICH6M) LPC Interface Bridge (rev 03)
00:1f.2 IDE interface: Intel Corporation 82801FBM (ICH6M) SATA Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus
Controller (rev 03)
01:00.0 VGA compatible controller: ATI Technologies Inc M22 [Mobility Radeon X300]
02:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5751M Gigabit
Ethernet PCI Express (rev 11)
0b:00.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev 8d)
0b:00.1 Generic system peripheral [0805]: Ricoh Co Ltd R5C822
SD/SDIO/MMC/MS/MSPro Host Adapter (rev 13)
0b:02.0 Network controller: Intel Corporation PRO/Wireless 2200BG Network
Connection (rev 05)

Also applicable to FC6
Comment 1 Nicolas A. Corrarello 2007-06-01 17:09:48 EDT
Sysreport attached
Comment 2 Nicolas A. Corrarello 2007-06-01 17:21:01 EDT
Created attachment 155941 [details]
Sysreport
Comment 3 Roberto Ragusa 2007-06-23 09:14:16 EDT
The same problem happens to me. More data points:

- I confirm it applies to FC6 too.
- It is not compiz specific, it sometimes happens with googleearth or beryl too;
it looks like a 3D acceleration issue.
- My machine is a T42p (01:00.0 VGA compatible controller: ATI Technologies Inc
M10 NT [FireGL Mobility T2] (rev 80))
Comment 4 Phillip Ezolt 2007-08-30 13:35:04 EDT
(!! COULD the OWNER -or- the submitter of this change the type from 'compiz' to
xorg-x11-drv-ati? !!! )

...
I also have a T43 with an X300. 

My symptoms are slightly different.  My box hangs (I can't toggle the keyboard
LEDS, etc), but I am still able move the mouse cursor. (but am unable to
manipulate any of the windows..) 

Possibly unrelated, when things ARE working, compiz sometimes leaves an extra
row of pixels around the outside of the windows. (Off by one error? ) 

I notice that I always received the following warning in my 'messages' file
before I reboot: 
"
Aug 30 12:09:01 localhost kernel: Uhhuh. NMI received for unknown reason b1 on
CPU 0.
Aug 30 12:09:01 localhost kernel: You have some hardware problem, likely on the
PCI bus.
Aug 30 12:09:01 localhost kernel: Dazed and confused, but trying to continue
"

Running with: xorg-x11-drv-ati-6.6.3-4.fc7

lspci details: 

01:00.0 VGA compatible controller: ATI Technologies Inc M22 [Mobility Radeon
X300] (prog-if 00 [VGA])
        Subsystem: IBM Unknown device 056e
        Flags: bus master, fast devsel, latency 0, IRQ 16
        Memory at c0000000 (32-bit, prefetchable) [size=128M]
        I/O ports at 3000 [size=256]
        Memory at a8100000 (32-bit, non-prefetchable) [size=64K]
        [virtual] Expansion ROM at a8120000 [disabled] [size=128K]
        Capabilities: [50] Power Management version 2
        Capabilities: [58] Express Endpoint IRQ 0
        Capabilities: [80] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0
Enable-
        Capabilities: [100] Advanced Error Reporting
Comment 5 darrell pfeifer 2007-09-08 15:53:27 EDT
I also have a radeon X300 video card that is exhibiting the 'dazed and confused'
NMI problem

xorg-x11-drv-ati-6.7.192-1.fc8
compiz-0.5.2-9.0ec3ec.fc8
01:00.0 VGA compatible controller: ATI Technologies Inc M22 [Mobility Radeon X300]

The NMI invariably happens with a new window is being draw on the screen.
Occasionally it happens when pulling down a menu.

I hang for me is recent. I didn't have the problem at all until several weeks
ago when both compiz and the ati driver were updated. Switched back to
non-compiz and haven't had any problems.

It probably is more of an ati driver problem since google earth has also stopped
working for me.
Comment 6 Matěj Cepl 2007-09-11 19:50:49 EDT
Created attachment 193121 [details]
reporter's /etc/X11/xorg.conf from sysreport report
Comment 7 Matěj Cepl 2007-09-11 19:51:22 EDT
Created attachment 193131 [details]
reporter's /var/log/Xorg.0.log from sysreport report
Comment 8 Matěj Cepl 2007-09-11 19:53:18 EDT
(In reply to comment #5)
> It probably is more of an ati driver problem since google earth has also stopped
> working for me.

You are right. Changing components.
Comment 9 Angelo Lisco 2007-10-05 16:28:13 EDT
Hi guys,
i think this is a duplicate of bug 219632
https://bugzilla.redhat.com/show_bug.cgi?id=242151

Same problem in ubuntu. For reference:
https://bugs.launchpad.net/fedora/+source/xserver-xorg-video-ati/+bug/108527
Comment 10 Matěj Cepl 2007-10-05 17:55:01 EDT
Angelo, I think you are right. Closing as duplicate.

*** This bug has been marked as a duplicate of 219632 ***

Note You need to log in before you can comment on or make changes to this bug.