Bug 219662 - install fails: libpython2.5.so.1.0 not found
Summary: install fails: libpython2.5.so.1.0 not found
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: powerpc Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
Keywords:
: 219888 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-12-14 18:05 UTC by John Reiser
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-15 14:48:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The point where anaconda dies (8.41 KB, image/png)
2006-12-14 22:07 UTC, Bas Mevissen
no flags Details

Description John Reiser 2006-12-14 18:05:11 UTC
Description of problem: Attempting to install using today's Rescue CD for
PowerPC, anaconda appears to start but fails immediately with the text message:
/urs/bin/python: error while loading shared libraries: libpython2.5.so.1.0:
cannot open shared object file: no such file or directory.


Version-Release number of selected component (if applicable):


How reproducible: always


Steps to Reproduce:
1. boot PowerPC Rescue CD with boot: linux
2. accept defauls for language and keyboard; specify HTTP, IP4 only, DHCP,
mirror, directory
3.
  
Actual results:
install terminated abnormally (very soon after "running anaconda, ..." because
libpythong2.5.so.1.0 cannot be found

Expected results:
install proceeds

Additional info:

Comment 1 Bas Mevissen 2006-12-14 22:07:19 UTC
Created attachment 143706 [details]
The point where anaconda dies

Same problem on i386 architecture in Xen guest

Comment 2 Bas Mevissen 2006-12-14 22:27:50 UTC
So problem seems arch independant.

Comment 3 Jeremy Katz 2006-12-15 14:48:55 UTC
Fix for this is in CVS, but other things are breaking the build right now. 

I'll hopefully get those taken care of today.  Then there's just some other
python2.5 fallout that needs fixing (pyxf86config seems to play things a little
too fast and loose with refcounting)

Comment 4 Bas Mevissen 2006-12-15 15:01:23 UTC
OK, thanks.
From the process point of view: why not first put it to resolved and then close
after you recieve confirmation of the original submitter?

Comment 5 Chris Lumens 2006-12-16 00:52:00 UTC
*** Bug 219888 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.