Bug 219746 - yumex is stopped in the yum package sqlitesack.py.
yumex is stopped in the yum package sqlitesack.py.
Status: CLOSED DUPLICATE of bug 220750
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-14 22:56 EST by MASAO TAKAHASHI
Modified: 2014-01-21 17:56 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-03 09:36:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description MASAO TAKAHASHI 2006-12-14 22:56:24 EST
Description of problem:
 yumex is top in the yum package.

Version-Release number of selected component (if applicable):
 yum-3.0.1-5.fc7
 yumex-1.2.0-1.0.fc7
 python-2.5-5.fc7


How reproducible:
 to execute yumex

Steps to Reproduce:
1. recompile yumex in rawhide environment.
2. execute yumex
3.
  
Actual results:
  yum executing is stopped.

Expected results:


Additional info:
  Error log is below.
 -----------------------------
Component: yumex
Version: 1.2.0
Summary: TBe83547cb sqlitesack.py:446:simplePkgList:ProgrammingError: SQLite
objects created in a thread can only be used in that same thread.The object was
created in thread id -1240970352 and this is thread id -1208543552

Traceback (most recent call last):
  File "/usr/share/yumex/yumexmain.py", line 1106, in <module>
    mainApp = YumexMainApplication()
  File "/usr/share/yumex/yumexmain.py", line 541, in __init__
    self.setup_yum()
  File "/usr/share/yumex/yumexmain.py", line 995, in setup_yum
    self.yumexbase.build_package_lists( self.recentlimit, pkglists )
  File "/usr/lib/python2.5/site-packages/yumex/yumexBase.py", line 445, in
build_package_lists
    self.doUpdateSetup()
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 357, in
doUpdateSetup
    self.pkgSack.simplePkgList())
  File "/usr/lib/python2.5/site-packages/yum/packageSack.py", line 303, in
simplePkgList
    return self._computeAggregateListResult("simplePkgList")
  File "/usr/lib/python2.5/site-packages/yum/packageSack.py", line 323, in
_computeAggregateListResult
    sackResult = apply(method, args)
  File "/usr/lib/python2.5/site-packages/yum/sqlitesack.py", line 446, in
simplePkgList
    cur = cache.cursor()
ProgrammingError: SQLite objects created in a thread can only be used in that
same thread.The object was created in thread id -1240970352 and this is thread
id -1208543552

Local variables in innermost frame:
simplelist: []
rep: development
cache: <sqlite3.Connection object at 0x94477a0>
self: <yum.sqlitesack.YumSqlitePackageSack instance at 0x99ee18c>
Comment 1 Tim Lauridsen 2006-12-18 04:13:21 EST
Look like the sqlite3 included in Python 2.5, dont like to be used in threads :-)
I have to investigate this some more.
Comment 2 Tim Lauridsen 2007-01-03 09:36:42 EST

*** This bug has been marked as a duplicate of 220750 ***

Note You need to log in before you can comment on or make changes to this bug.