Bug 220750 - yumex dont work with python 2.5 (sqlite trackback)
Summary: yumex dont work with python 2.5 (sqlite trackback)
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
(Show other bugs)
Version: 6
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Tim Lauridsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 219746 221034 221699 (view as bug list)
Depends On:
Blocks: FE7Target
TreeView+ depends on / blocked
 
Reported: 2006-12-25 19:52 UTC by kurt dicke
Modified: 2007-11-30 22:11 UTC (History)
4 users (show)

Fixed In Version: yumex-1.9.6-1.0.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-02 21:37:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description kurt dicke 2006-12-25 19:52:52 UTC
Description of problem:
I installed fc6 yesterday from scratch.
I used yumex to do an update and did a select all.
yumex then ran for about 45 minutes and appeared to be near completion when
the window exited.
I tried starting yumex again and it again exited.
I rebooted and ran yumex again and received exception and request to submit bug.
I read the only yumex bug I found and the trace didn't match so I'm submitting a
new bug.

The text from the exception box:
Component: yumex
Version: 1.2.1
Summary: TBe83547cb sqlitesack.py:446:simplePkgList:ProgrammingError: SQLite
objects created in a thread can only be used in that same thread.The object was
created in thread id -1226904688 and this is thread id -1208301888

Traceback (most recent call last):
  File "/usr/share/yumex/yumexmain.py", line 1108, in <module>
    mainApp = YumexMainApplication()
  File "/usr/share/yumex/yumexmain.py", line 541, in __init__
    self.setup_yum()
  File "/usr/share/yumex/yumexmain.py", line 995, in setup_yum
    self.yumexbase.build_package_lists( self.recentlimit, pkglists )
  File "/usr/lib/python2.5/site-packages/yumex/yumexBase.py", line 445, in
build_package_lists
    self.doUpdateSetup()
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 357, in
doUpdateSetup
    self.pkgSack.simplePkgList())
  File "/usr/lib/python2.5/site-packages/yum/packageSack.py", line 303, in
simplePkgList
    return self._computeAggregateListResult("simplePkgList")
  File "/usr/lib/python2.5/site-packages/yum/packageSack.py", line 323, in
_computeAggregateListResult
    sackResult = apply(method, args)
  File "/usr/lib/python2.5/site-packages/yum/sqlitesack.py", line 446, in
simplePkgList
    cur = cache.cursor()
ProgrammingError: SQLite objects created in a thread can only be used in that
same thread.The object was created in thread id -1226904688 and this is thread
id -1208301888

Local variables in innermost frame:
simplelist: []
rep: development
cache: <sqlite3.Connection object at 0x9bf3110>
self: <yum.sqlitesack.YumSqlitePackageSack instance at 0x9c145cc>


Version-Release number of selected component (if applicable):
1.2.1

How reproducible:
Sorry, my steps are vague.

Steps to Reproduce:
1. new install fc6
2. yumex, select all, install
3. reboot, yumex
  
Actual results:
yumex exception

Expected results:
yumex success

Additional info:

Comment 1 Tim Lauridsen 2006-12-26 08:26:23 UTC
This error happens because of Python 2.5, yumex 1.2.1 dont work with python 2.5
at the moment.
Python 2.5 is not a part of FC6, it only available in Rawhide, it will soon
release a yumex 1.9.1 prerelease there works with python 2.5

Comment 2 Saikat Guha 2006-12-26 17:18:36 UTC
Confirming this bug for 
 yumex-1.2.1-1.0.fc7
 python-2.5-6.fc7
on a fully updated rawhide.
Will update this thread when yumex 1.9.1 is out.

Comment 3 Tim Lauridsen 2007-01-03 14:34:49 UTC
*** Bug 221034 has been marked as a duplicate of this bug. ***

Comment 4 Tim Lauridsen 2007-01-03 14:36:46 UTC
*** Bug 219746 has been marked as a duplicate of this bug. ***

Comment 5 Tim Lauridsen 2007-01-03 14:44:50 UTC
I have current 1.9.1 (PreRelease1) should work with python 2.5, please check it
out a report back to me.

get it here :

http://www.yum-extender.org/dnl/yumex/devel/

The changes is to big to get into yumex 1.2.x, so i will not work with python
2.5, only the 1.9.x branch will be working with python 1.5.


Comment 6 kurt dicke 2007-01-05 23:08:59 UTC
That version works for me. Changing state to Verified. thanks.


Comment 7 Tim Lauridsen 2007-01-07 11:50:12 UTC
*** Bug 221699 has been marked as a duplicate of this bug. ***

Comment 8 Peter van Egdom 2007-07-02 21:37:54 UTC
Thank you for the bug report. Closing bug as per comment #5 and comment #6. 
Fedora 7 contains "yumex-1.9.6".


Note You need to log in before you can comment on or make changes to this bug.