Bug 219920 - Installation of "mutt" pulls in package from "FE"
Installation of "mutt" pulls in package from "FE"
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 220551 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-16 10:09 EST by Joachim Frieben
Modified: 2014-01-21 17:56 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-16 11:56:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2006-12-16 10:09:39 EST
Description of problem:
After a fairly minimum install from the "rawhide" tree, I install "mutt"
by means of "yum install mutt". By default, "FC" and "FE" repositories
are enabled. After resolving dependencies, "yum" requires "exim" from
"FE" to be installed as prerequisite of "mutt".
Executing "rpm -e --test exim" after the install returns a message
according to which "/usr/sbin/sendmail" is required by "mutt".
A core package like "mutt" must not depend on a package from "FE". The
dependency should have led to "yum" scheduling "sendmail" or "postfix"
for install. Querying "rpm -qf /usr/sbin/sendmail" instead returns
"exim-4.63-6.fc7".

Version-Release number of selected component (if applicable):
mutt-1.4.2.2-5.fc7

How reproducible:
Always.

Steps to Reproduce:
1. Perform minimum install from the "rawhide" tree.
2. Install "mutt" mail client.
  
Actual results:
"yum" pulls in "exim-4.63-6.fc7" in order to provide "/usr/sbin/sendmail".

Expected results:
"yum" pulls in "sendmail-8.13.8-3.1" or an alternative package from "FC"
that provides "/usr/sbin/sendmail".

Additional info:
None.
Comment 1 Seth Vidal 2006-12-16 11:56:19 EST
3 programs provide /usr/sbin/sendmail
sendmail
postfix
exim

since yum has no way of knowing which of those is better, and no reason to care,
it sorts them using the sort order it's been using for years - shortest package
name.

so exim wins.
Comment 2 Joachim Frieben 2006-12-16 14:50:49 EST
(In reply to comment #1)
> 3 programs provide /usr/sbin/sendmail
"yum" should be smart enough to look in "FC" first instead of "FE" and
optionally, in case that various alternatives exist, prompt the user to
make a choice. Your point maybe right for packages within a single
repository, but "FE" is an add-on repository which is by no means
comparable to "FC".
Comment 3 Seth Vidal 2006-12-16 16:05:08 EST
The distinction between fedora extras and fedora core is dissolving in fedora 7.

At which point this doesn't have much meaning.
Comment 4 Miroslav Lichvar 2006-12-22 02:55:33 EST
*** Bug 220551 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.