Bug 219924 - Refactoring doesn't work in Eclipse CDT!
Refactoring doesn't work in Eclipse CDT!
Status: CLOSED DUPLICATE of bug 183698
Product: Fedora
Classification: Fedora
Component: eclipse-cdt (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnston
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-16 12:51 EST by Michail Michailov
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-18 13:12:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michail Michailov 2006-12-16 12:51:12 EST
Description of problem:
The most useful feature in Eclipse -- refactoring doesn't work in Eclipse CDT if
running Eclipse on gcj (native)! Refactoring does work, if running eclipse on
sun's Java VM.

Version-Release number of selected component (if applicable):
Eclipse platform 3.2.0 - CDT Refactoring 3.1.1.200609291545

How reproducible:
always

Steps to Reproduce:
1. Select a variable
2. Choose Refactor -> Rename from the context menu
3. Eneter a new name for the selected variable
4. Press Preview/OK
  
Actual results:
Messge box 'Refactoring doesn't change any code' appears

Expected results:
Changes in the current edit buffer in the variable's scope/Preview of the code
being refactored.

Additional info:
Comment 1 Jeff Johnston 2006-12-18 13:12:00 EST
This problem is a duplicate of 183698.  There is a bug in classpath whereby the
Matcher.reset() operation does not work properly.  Internal code in the CDT uses
this during refactoring "and" also for searches.  The result of the bug is that
the list of applicable files to look at for renaming or searching ends up being
the empty list.  A patch has been posted to gcc for the Classpath bug.  A
forth-coming gcc update will contain this fix.

*** This bug has been marked as a duplicate of 183698 ***

Note You need to log in before you can comment on or make changes to this bug.