Bug 183698 - Refactor->rename doesn't work
Refactor->rename doesn't work
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
: 218338 219924 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-02 16:25 EST by Igor Foox
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 4.1.1-33
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-08 04:03:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNU Compiler Collection 29703 None None None Never

  None (edit)
Description Igor Foox 2006-03-02 16:25:20 EST
Description of problem:
The renaming doesn't seem to do anything. When I try to refactor a function, I
get the renaming dialog, then when I click 'Preview' it says that the
refactoring doesn't seem to affect any code, and doesn't rename the function.

Version-Release number of selected component (if applicable):
eclipse-cdt-3.0.2

How reproducible:
Always.

Steps to Reproduce:
1. Create a new managed make project (C)
2. Create a .c file with a main function and another function, have main call
the other function.
3. Select the other function, choose Refactor->Rename in the menu, enter a new
name, click Perview.

  
Actual results:
Get a message saying 'The refactoring doesn't change any source code.'.

Expected results:
Refactor the damned mehotd.
Comment 1 Ben Konrath 2006-03-30 16:53:09 EST
Igor, Does it work with a proprietary vm?
Comment 2 Jeff Johnston 2006-11-01 15:27:57 EST
I have confirmed it works with our local JDK 1.5 copy.
Comment 3 Jeff Johnston 2006-11-06 14:46:55 EST
I have narrowed down the problem to a bug in classpath
java.util.regex.Matcher.reset()  Bug 29703 has been opened against classpath.
Comment 4 Jeff Johnston 2006-11-07 12:03:47 EST
The fix for 29703 needs to be brought into FC gcc.
Comment 5 Jeff Johnston 2006-12-04 16:39:35 EST
*** Bug 218338 has been marked as a duplicate of this bug. ***
Comment 6 Jakub Jelinek 2006-12-08 04:03:42 EST
Fixed in 4.1.1-33 and above, sorry, forgot to close this.
Comment 7 Iftikhar 2006-12-11 02:35:43 EST
Fixed in 4.1.1-33 of gcc? If so can you tell me the place from where i can get 
RPM installer of this gcc version?
Comment 8 Jeff Johnston 2006-12-18 13:12:13 EST
*** Bug 219924 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.