Bug 219980 - git clone via HTTP fails
Summary: git clone via HTTP fails
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: git-core (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Chris Wright
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 214710 219984 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-12-18 02:26 UTC by Horst H. von Brand
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version: git-1_5_0_2-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-19 22:30:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The message with a working patch (3.80 KB, patch)
2006-12-29 12:41 UTC, Horst H. von Brand
no flags Details | Diff

Description Horst H. von Brand 2006-12-18 02:26:26 UTC
Description of problem:
git pulling from http://jonas.nitro.dk/tig/tig.git

Version-Release number of selected component (if applicable):
git-core-1.4.4.2-2.fc7

How reproducible:
Always

Steps to Reproduce:
1. git clone http://jonas.nitro.dk/tig/tig.git
2.
3.
  
Actual results:
error: Unable to start request
error: Could not interpret heads/release as something to pull

Expected results:
Cloned repo

Additional info:

Comment 1 Horst H. von Brand 2006-12-18 02:39:01 UTC
The same works fine on SPARC (Aurora Corona), same version of git.

Comment 2 Horst H. von Brand 2006-12-28 02:27:01 UTC
This seems to be a curl problem with 7.16.0, as discussed in the git list.

Comment 3 Horst H. von Brand 2006-12-29 12:41:38 UTC
Created attachment 144536 [details]
The message with a working patch

This issue was discussed in the git list, and Junio C Hamano provided a
workaround (or fix?). Tested here, it works.

Comment 4 Horst H. von Brand 2006-12-29 12:43:08 UTC
*** Bug 219984 has been marked as a duplicate of this bug. ***

Comment 5 Horst H. von Brand 2007-01-01 17:04:23 UTC
It turned out to be a cURL bug, fixed in its CVS by the commit

  curl_easy_duphandle() sets the magic number in the new handle

(George Sherwood did the footwork to find this out).

Comment 6 Chris Wright 2007-03-19 22:30:27 UTC
This should be fixed since git-1.5.0.x.  Please reopen if issue persists.

Comment 7 Chris Wright 2007-03-19 22:46:24 UTC
*** Bug 214710 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.