Bug 220106 - RHNSat5: userlist |< < > >| buttons don't work
Summary: RHNSat5: userlist |< < > >| buttons don't work
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server   
(Show other bugs)
Version: 500
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jesus M. Rodriguez
QA Contact: Brandon Perkins
URL:
Whiteboard:
Keywords:
: 220105 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-12-18 22:14 UTC by Matt Domsch
Modified: 2008-03-14 01:59 UTC (History)
3 users (show)

Fixed In Version: sat510
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-14 01:59:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Matt Domsch 2006-12-18 22:14:40 UTC
Description of problem:
https://rhn.linuxdev.us.dell.com/rhn/users/ActiveList.do page shows buttons for
|< < > >| which are appropriately grayed or active, but clicking on the active 
buttons yields a list that is unchanged.  

The button marked ">" resolves to a URL:
https://rhn.linuxdev.us.dell.com/rhn/users/ActiveList.do?lower=1
but the list still starts from the top (I've got 65 active users, it should 
have shown me page 2).

Likewise the button for ">|" gives the same URL with "lower=1" on the end.

Typing in a different lower: value does solve it:
https://rhn.linuxdev.us.dell.com/rhn/users/ActiveList.do?lower=21

so merely the links provided by the buttons are being mis-calculated.


Version-Release number of selected component (if applicable):
rhn-satellite-4.9.0-14-redhat-linux-as-i386-4-embedded-oracle.iso

How reproducible:
always


Steps to Reproduce:
1. Go to the Users page
2. Click one of the previous or next page buttons

  
Actual results:
same page is produced starting from address 1

Expected results:
next page is produced.

Comment 1 Matt Domsch 2006-12-18 22:21:23 UTC
*** Bug 220105 has been marked as a duplicate of this bug. ***

Comment 2 Red Hat Bugzilla 2007-04-12 02:09:07 UTC
User bnackash@redhat.com's account has been closed

Comment 3 Jesus M. Rodriguez 2008-03-14 01:59:16 UTC
Fixed in the upcoming satellite release.


Note You need to log in before you can comment on or make changes to this bug.