Bug 220459 - mail-notification spikes the CPU on lost connection
mail-notification spikes the CPU on lost connection
Status: CLOSED DUPLICATE of bug 220457
Product: Fedora
Classification: Fedora
Component: mail-notification (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thorsten Leemhuis
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-21 09:59 EST by Russell Harrison
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-22 02:55:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Russell Harrison 2006-12-21 09:59:20 EST
Description of problem: mail-notification spikes the CPU if its connection to an
IMAP server goes away.


Version-Release number of selected component (if applicable):
mail-notification-3.0-10.fc6

How reproducible:  Setup a connection to an IMAP server where it can lose its
connection while the overall link is still up.  In my case my mail server is
behind the VPN.

Steps to Reproduce:
1. Connect to the VPN and notice mail-notification will alert you to your new mail.
2. Disconnect from the VPN. 
  
Actual results:  Mail-notification will spike the CPU.
It will stay in this state until either the VPN tunnel is restored or the
process is killed / shutdown manually.

Expected results:
mail-notification would realize that it has no route to the server and
disconnect as if the link on the interface had gone down as well.

Additional info:  I think this may have something to do with the IDLE setting
being enabled.
Comment 1 Thorsten Leemhuis 2006-12-22 02:55:00 EST

*** This bug has been marked as a duplicate of 220457 ***

Note You need to log in before you can comment on or make changes to this bug.