This service will be undergoing non-disruptive maintenance at 07:20 UTC, 2018-12-14. It is expected to last approximately 30 minutes
Bug 220457 - mail-notification spikes the CPU on lost connection
Summary: mail-notification spikes the CPU on lost connection
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: mail-notification (Show other bugs)
(Show other bugs)
Version: 6
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Thorsten Leemhuis
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 220459 (view as bug list)
Depends On: 223659
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-12-21 14:54 UTC by Russell Harrison
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 4.0-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-15 16:35:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Russell Harrison 2006-12-21 14:54:26 UTC
Description of problem: mail-notification spikes the CPU if its connection to an
IMAP server goes away.


Version-Release number of selected component (if applicable):
mail-notification-3.0-10.fc6

How reproducible:  Setup a connection to an IMAP server where it can lose its
connection while the overall link is still up.  In my case my mail server is
behind the VPN.

Steps to Reproduce:
1. Connect to the VPN and notice mail-notification will alert you to your new mail.
2. Disconnect from the VPN. 
  
Actual results:  Mail-notification will spike the CPU.
It will stay in this state until either the VPN tunnel is restored or the
process is killed / shutdown manually.

Expected results:
mail-notification would realize that it has no route to the server and
disconnect as if the link on the interface had gone down as well.

Additional info:  I think this may have something to do with the IDLE setting
being enabled.

Comment 1 Thorsten Leemhuis 2006-12-22 07:55:03 UTC
*** Bug 220459 has been marked as a duplicate of this bug. ***

Comment 2 Thorsten Leemhuis 2006-12-22 07:56:14 UTC
Could you try to rebuild the 4.0-rc2 SRPM from devel for FC-6. I likely fixes
this problem. 

Comment 3 Thorsten Leemhuis 2007-01-03 06:12:34 UTC
There is also a bug report upstream at
https://savannah.nongnu.org/bugs/?18367

Comment 4 Thorsten Leemhuis 2007-01-27 15:11:47 UTC
FYI: I'm not going to update to 208774 before 223659 is fixed

Comment 5 Thorsten Leemhuis 2007-02-15 16:35:49 UTC
should be fixed in 4.0


Note You need to log in before you can comment on or make changes to this bug.