Bug 220460 - audit-lib-python should put AuditMsg.* in /usr/lib/python2.5/site-packages
audit-lib-python should put AuditMsg.* in /usr/lib/python2.5/site-packages
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: audit (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Grubb
Brian Brock
:
: 220456 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-21 10:01 EST by Tom London
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-28 09:41:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom London 2006-12-21 10:01:35 EST
Description of problem:
audit-libs-python puts some packages in python2.4 and some in python 2.5:

[tbl@localhost site-packages]$ rpm -ql audit-libs-python
/sbin/audispd
/usr/lib/python2.4/site-packages/AuditMsg.py
/usr/lib/python2.4/site-packages/AuditMsg.pyc
/usr/lib/python2.4/site-packages/AuditMsg.pyo
/usr/lib/python2.5/site-packages/_audit.so
/usr/lib/python2.5/site-packages/audit.py
/usr/lib/python2.5/site-packages/audit.pyc
/usr/lib/python2.5/site-packages/audit.pyo
[tbl@localhost site-packages]$ 

This breaks setroubleshoot.....

Version-Release number of selected component (if applicable):
audit-libs-python-1.3.1-1.fc7

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 John Dennis 2006-12-21 15:41:33 EST
*** Bug 220456 has been marked as a duplicate of this bug. ***
Comment 2 John Dennis 2006-12-21 16:07:20 EST
The problem is audisp/Makefile has this line:

LIBDIR ?= $(PREFIX)/lib/python2.4/site-packages

The other problem is audisp/Makefile seems to be "hardcoded" it should be
generated by configure.ac from audisp/Makefile.am. To do this two things have to
happen, audisp/Makefile.am has to be added and then it has to be referenced in
configure.ac in the AC_OUTPUT macro.

audisp/Makefile.am should have something like this:

PYTHON_FILES =				\
	AuditMsg.py

audispdir = $(pythondir)
audispdir_PYTHON = $(PYTHON_FILES)

The above may not 100% correct, it's off the top of my head, but should be close
Comment 3 John Dennis 2006-12-21 16:11:50 EST
Also, configure.ac has AM_PATH_PYTHON(2.4), I don't think it should be
hardcoded, should just be AM_PATH_PYTHON, right?
Comment 4 Steve Grubb 2006-12-21 20:23:37 EST
audit-1.3.1-2 was built to hopefully solve this problem. Thanks for reporting it.

Note You need to log in before you can comment on or make changes to this bug.