Bug 220469 - HTS 5.0-14 not detecting all USB storage devices
HTS 5.0-14 not detecting all USB storage devices
Status: CLOSED DUPLICATE of bug 220467
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness) (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Greg Nichols
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-21 11:01 EST by Gregory Feiner
Modified: 2007-04-18 13:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-03 10:24:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gregory Feiner 2006-12-21 11:01:17 EST
Description of problem:
When creating tests plans, hts fails to add some USB devices into the test 
plan forcing the user to manually add it.  One USB device in question is a HP 
USB floppy drive model D353FUE.  Even though the OS sees the device and it is 
mounted, HTS will not add it to the test plan.  I had to manually add it into 
the test plan using:
hts plan --add --test=floppy –
udi=/org/freedesktop/Hal/devices/storage_serial_MITSUMI_MITSUMI_USB_FDD

This was using ProLiant DL320 G5, RHEL5 32bit build 20061207.4

Version-Release number of selected component (if applicable): 5.0-14

Steps:
1. Install OS on server
2. plug in floppy with media, let it mount
3. install test kit 5.0-14
4. create test plan.  floppy test will not get created.

Expected results: kit should create a floppy test for the USB floppy.
Comment 1 Gregory Feiner 2006-12-21 19:37:22 EST
Even though I was able to use Hardware Manager to find the USB Floppy's udi and
manually add the floppy test to the test plan, the floppy test ultimately
failed.  It complained it could not find any floppy device.
Comment 2 Greg Nichols 2007-01-03 10:24:16 EST

*** This bug has been marked as a duplicate of 220467 ***

Note You need to log in before you can comment on or make changes to this bug.