Bug 220481 - Resource temporarily unavailable burning DVD-/+RW
Resource temporarily unavailable burning DVD-/+RW
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: k3b (Show other bugs)
5.1
x86_64 Linux
high Severity urgent
: ---
: ---
Assigned To: Roman Rakus
: Reopened
: 238857 454216 (view as bug list)
Depends On: 212257
Blocks: 391501 223278
  Show dependency treegraph
 
Reported: 2006-12-21 12:10 EST by Amit Bhutani
Modified: 2014-01-12 19:06 EST (History)
12 users (show)

See Also:
Fixed In Version: RHBA-2008-0591
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-16 09:35:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Amit Bhutani 2006-12-21 12:10:43 EST
+++ This bug was initially created as a clone of Bug #212257 +++

Description of problem: 
When attempting to burn a dvd-/+rw with growisofs the systems reports :-( unable
to anonymously mmap 16777216: Resource temporarily unavailable. If I change the
ulimits for (max locked memory) with "ulimit -l 40000kb or more" the issue is
not seen. the default for max locked memory is set to 32kb see ulimit dump below.

ULIMIT DEFAULTS RHEL5

core file size          (blocks, -c) 0
data seg size           (kbytes, -d) unlimited
max nice                        (-e) 0
file size               (blocks, -f) unlimited
pending signals                 (-i) 8180
max locked memory       (kbytes, -l) 32
max memory size         (kbytes, -m) unlimited
open files                      (-n) 1024
pipe size            (512 bytes, -p) 8
POSIX message queues     (bytes, -q) 819200
max rt priority                 (-r) 0
stack size              (kbytes, -s) 10240
cpu time               (seconds, -t) unlimited
max user processes              (-u) 8180
virtual memory          (kbytes, -v) unlimited
file locks                      (-x) unlimited

Version-Release number of selected component (if applicable):

How reproducible:
100%

Steps to Reproduce:
1.Type growisofs -Z /dev/hda=/root/DVD_IMAGE.iso
2.
3.
  
Actual results:


Expected results:


Additional info:

-- Additional comment from pm-rhel@redhat.com on 2006-10-26 12:45 EST --
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux release.  Product Management has requested further review
of this request by Red Hat Engineering.  This request is not yet committed for
inclusion in release.

-- Additional comment from sbenjamin@redhat.com on 2006-10-27 13:43 EST --
Engineering comments :
So, this seems to be a result of growisofs wanting to lock a lot of shared
memory and 2.6.16 and later kernels not allowing it by default.

And there don't appear to be any "easy" answers from upstream growisofs as far
as I can tell.

Given the other ways available of burning (cdrecord) and the availability of a
workaround (ulimit), I don't think that this should block beta2.  We can
continue to investigate avenues to a better solution for RC

-----------

At least on the box I have, cdrecord does not work, so the only choice is growisofs.

It can be worked around with --use-the-force-luke=bufsize=4M.

-- Additional comment from harald@redhat.com on 2006-11-02 05:36 EST --
built dvd+rw-tools-6.1-5

-- Additional comment from amit_bhutani@dell.com on 2006-11-03 00:13 EST --
Could you please post this to a people page so we could regress ? The last build
we have from RH was built 10/20 so it definitely does not contain this fix.

-- Additional comment from mclasen@redhat.com on 2006-11-03 07:38 EST --
Setting dev ack +, since there is a built fix.

-- Additional comment from harald@redhat.com on 2006-11-03 08:28 EST --
http://people.redhat.com/harald/downloads/dvd+rw-tools/dvd+rw-tools-6.1-5/

-- Additional comment from harald@redhat.com on 2006-11-03 10:12 EST --
*** Bug 213579 has been marked as a duplicate of this bug. ***

-- Additional comment from harald@redhat.com on 2006-11-06 11:41 EST --
please try
http://people.redhat.com/harald/downloads/dvd+rw-tools/dvd+rw-tools-6.1-5/

-- Additional comment from Rogelio_Noriega@Dell.Com on 2006-11-06 17:31 EST --
I'm still seeing the same exact issue with dvd+rw-tools-6.1-5 no change.

-- Additional comment from harald@redhat.com on 2006-11-07 02:49 EST --
Hmm, does this only happen on x86_64?

-- Additional comment from harald@redhat.com on 2006-11-07 06:25 EST --
Please try:
http://redhat.download.fedoraproject.org/pub/fedora/linux/core/updates/6/x86_64/dvd+rw-tools-7.0-0.fc6.2.x86_64.rpm

-- Additional comment from harald@redhat.com on 2006-11-07 06:36 EST --
which works for me on i386

-- Additional comment from Rogelio_Noriega@Dell.Com on 2006-11-07 14:16 EST --
Issue resolved with dvd+rw-tools-7.0-0. If I'm not mistaken 7.0 does support
Blue Ray optical drives is that right?

-- Additional comment from jturner@redhat.com on 2006-11-22 10:59 EST --
[root@test175 4.92]# find . -name "dvd*" -print
./i386/os/Server/dvd+rw-tools-7.0-0.el5.2.i386.rpm
./i386/debug/dvd+rw-tools-debuginfo-7.0-0.el5.2.i386.rpm
./ppc/os/Server/dvd+rw-tools-7.0-0.el5.2.ppc.rpm
./ppc/debug/dvd+rw-tools-debuginfo-7.0-0.el5.2.ppc.rpm
./s390x/os/Server/dvd+rw-tools-7.0-0.el5.2.s390x.rpm
./s390x/debug/dvd+rw-tools-debuginfo-7.0-0.el5.2.s390x.rpm
./x86_64/os/Server/dvd+rw-tools-7.0-0.el5.2.x86_64.rpm
./x86_64/debug/dvd+rw-tools-debuginfo-7.0-0.el5.2.x86_64.rpm
./ia64/os/Server/dvd+rw-tools-7.0-0.el5.2.ia64.rpm
./ia64/debug/dvd+rw-tools-debuginfo-7.0-0.el5.2.ia64.rpm
./source/SRPMS/dvd+rw-tools-7.0-0.el5.2.src.rpm
[root@test175 4.92]# pwd
/mnt/redhat/rel-eng/RHEL5-Server-20061117.0/4.92


-- Additional comment from harald@redhat.com on 2006-12-15 08:22 EST --
please try
http://people.redhat.com/harald/downloads/dvd+rw-tools/dvd+rw-tools-7.0-0.el5.3/

-- Additional comment from amit_bhutani@dell.com on 2006-12-20 01:30 EST --
Reopening bug since Harald's comment #22 just exposed that Dell never actually
regressed this with an EL5 version of the package rather just the Fedora updates
package, so the issue should not have been closed to begin with. 

Will attempt to set it to a NEEDINFO on Roger @ Dell after I post this comment
since I don't currently see a way of doing that while reopening the bug at the
same time.

-- Additional comment from Rogelio_Noriega@Dell.Com on 2006-12-20 14:12 EST --
I upgraded dvd+rw-tools to dvd+rw-tools-7.0-0.el5.3 burning a dvd on a VT 
console passed without errors but I still get :-( unable
to anonymously mmap 16777216: Resource temporarily unavailable. using k3b in X.

-- Additional comment from harald@redhat.com on 2006-12-21 03:44 EST --
Try to use the command line. If that works, we should reassign this bug to k3b.
You could also use nautilus (gnome file manager) to burn DVDs.

-- Additional comment from john_hull@dell.com on 2006-12-21 08:10 EST --
DVD burning from the command line works with the latest dvd+rw-tools. Burning a
DVD from k3b doesn't

-- Additional comment from harald@redhat.com on 2006-12-21 08:19 EST --
so please open a new bug against k3b. thank you!
Comment 1 Amit Bhutani 2006-12-21 12:13:31 EST
Opened this against k3b per Harald's suggestion in bz212257.
Comment 2 Joe Christy 2007-01-02 23:02:35 EST
On *FC6*, I experience the problems discussed up through and including comment
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=220481#c1.

Sadly I am "not authorized to access bug #212257."

Is there some way to gain access to this bz, or better yet, fix it for FC6, or
do I need to open a new bug against FC6 k3b?
Comment 3 RHEL Product and Program Management 2007-01-11 08:20:47 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Harald Hoyer 2007-01-15 07:18:56 EST
hmm, worksforme with the new dvd+rw-tools packages...
Comment 5 Rogelio Noriega 2007-01-18 20:27:46 EST
I'm still seeing the same issue the problem is with k3b not dvd+rw-tools.

:-( unable to anonymously mmap 16777216: Resource temporarily unavailable. using
k3b. DVD burning works fine from the commandline and nautilus. The RPMS in RCS7
are dvd+rw-tools-7.0-0.el5.3 and k3b-0.12.15-3.1.1.
Comment 7 Rogelio Noriega 2007-01-19 13:16:33 EST
k3b-0.12.17.1.el5 did not resolve the issue. I still get Resource temporarily
unavailable.
Comment 8 Amit Bhutani 2007-01-24 09:50:31 EST
Putting it back to ASSIGNED based on negative test results from comment #7.
Comment 9 Amit Bhutani 2007-01-24 09:52:31 EST
Tracking this against RHEL 5.1.0 as the chances of this making RHEL 5.0.0 at
this point appear to be slim to none.
Comment 11 Phil Knirsch 2007-05-10 11:54:15 EDT
One thing that Than Ngo found out which you might try is to:

1) Start K3b
2) Go to Settings->Configure K3b
3) Selete the Advanced tab in the Writing section
4) Activate "Manual writing buffer size" and set it to 4MB

If you do that this should fix the error. Please let me know if it does. Because
then we'd know how to fix it properly in K3b resp. have an easy workaround.

Thanks,

Read ya, Phil
Comment 12 Dilpreet Gulati 2007-06-06 10:31:03 EDT
The message "unable to anonymously mmap 16777216: Resource temporarily 
unavailable"
is not seen on Setting "Manual writing buffer size" to 4MB.
Comment 13 Dilpreet Gulati 2007-06-06 14:14:53 EDT
Setting status back to assigned
Comment 14 Nicola Ricciarelli 2007-06-14 13:08:20 EDT
I've just installed Fedora7 and it has the same problem insdicated in the bug
post message and activating "Manual writing buffer size" and setting it to 50MB
the result is the same reported in Comment12 (maybe 50MB are too much but I
preferred to setup a more "safe" value).
Comment 18 Roman Rakus 2008-04-18 05:50:27 EDT
*** Bug 238857 has been marked as a duplicate of this bug. ***
Comment 23 errata-xmlrpc 2008-07-16 09:35:47 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0591.html
Comment 24 Roman Rakus 2008-07-22 08:34:32 EDT
*** Bug 454216 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.