Bug 238857 - k3b burn DVD or a DVD iso always failed.
k3b burn DVD or a DVD iso always failed.
Status: CLOSED DUPLICATE of bug 220481
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: k3b (Show other bugs)
5.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Roman Rakus
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-03 09:40 EDT by Spencer Tsai
Modified: 2014-01-12 19:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-18 05:50:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
RHEL5 k3b DVD burn failed, screen capture. (307.35 KB, image/png)
2007-05-03 09:40 EDT, Spencer Tsai
no flags Details

  None (edit)
Description Spencer Tsai 2007-05-03 09:40:34 EDT
Description of problem:
k3b burn DVD or a DVD iso always failed.

[System Configureration]
Platform:    Gateway E-9522R
CPU:            AMD Opteron 2218, 2.6GHz, Dual Processors, F3 stepping
Memory:     ELPIDA, DDR2 667, 1GB x 12ea, total 12GB
Storage:      LSI 1068E, RAID1
Disk:             Seagate ST373454SS (SAS 3.5" 73GB)
Driver:          RHEL5 embedded
DVD-RW:    Lite-On SSM-8515S
Externel DVD-RW:     SONY DRX-710UL (USB2.0)

Version-Release number of selected component (if applicable):
k3b-0.12.17-1.el5.i386.rpm
k3b-0.12.17-1.el5.x86_64.rpm
How reproducible:
always

Steps to Reproduce:
1. Copy k3b rpm from RHEL5 Client version.
2. In RHEL5 Server, install k3b rpm and then start up K3b.
3. Select a DVD iso to burn.
4. k3b shows error message, then stop burning.
        unable to anonymously mmap 33554432: Resource temporarily uavaila...
        Fatal error at startup: Resource temporarily uavailable
  
Actual results:
1. k3b burn DVD or a DVD iso always failed.
2. k3b format a DVD-RW successfully.
3. k3b burn a CD iso must without burnfree enabled, or else will be failed. 

Expected results:


Additional info:
1. Change internel DVD writer to these devices, all failed DVD burn test.
     Lite-On   SSW-8015S
     Toshiba  TS-L632
     TEAC       DV-W24E
2. Download k3b 1.0.1 to compile for DVD burn test, still failed.
3. Change OS to RHEL4 U4 ES and SLES10, k3b DVD burn test all passed.
Comment 1 Spencer Tsai 2007-05-03 09:40:35 EDT
Created attachment 154034 [details]
RHEL5 k3b DVD burn failed, screen capture.
Comment 2 Harald Hoyer 2007-05-03 11:07:35 EDT
are you sure dvd+rw-tools is the RHEL5 version?
Comment 3 Spencer Tsai 2007-05-03 21:47:11 EDT
Yes, I am very sure dvd+rw-tools is the RHEL5 version.
All I do is copy k3b rpm from RHEL5 Client to RHEL5 Server for DVD burn using.
And I havd reinstalled OS to verify this issue for several times in 3 different 
platforms.
They all got the same DVD burn failed result on RHEL5.
Comment 4 Harald Hoyer 2007-05-04 01:46:48 EDT
1. try burning as root
2. try as user setting in /etc/security/limits.conf
hard    memlock         unlimited
Comment 5 Harald Hoyer 2007-05-04 01:48:06 EDT
sry, /etc/security/limits.conf:
* hard    memlock         unlimited
Comment 6 Spencer Tsai 2007-05-04 02:41:18 EDT
Tried the 2 suggest methods, but k3b still pop out the same error message.
k3b DVD burn test still failed.
Comment 7 Carl-Johan Kjellander 2007-05-12 06:09:18 EDT
Try this as root:

ulimit -l unlimited
k3b&

It worked for me in FC6.
Comment 8 Spencer Tsai 2007-05-13 23:08:48 EDT
Run all command as root,
And try to run "ulimit -l unlimited" before "k3b&".
But k3b still reports the same error message.
k3b DVD burn test still failed.
(OS is RHEL5 Server x86-64)
Comment 9 Harald Hoyer 2007-05-29 05:21:59 EDT
1) Start K3b
2) Go to Settings->Configure K3b
3) Selete the Advanced tab in the Writing section
4) Activate "Manual writing buffer size" and set it to 4MB

If you do that this should fix the error. Please let me know if it does. Because
then we'd know how to fix it properly in K3b resp. have an easy workaround.

Comment 10 Spencer Tsai 2007-05-29 08:11:11 EDT
Hi Harald,
You are great. This action really works.
Now, k3b can burn DVD iso successfully.
Thank you for your advice.
Comment 11 RHEL Product and Program Management 2007-06-05 16:28:08 EDT
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Since this
bugzilla is in a component that is not approved for the current
release, it has been closed with resolution deferred.  You may
reopen this bugzilla for consideration in the next release.
Comment 13 Roman Rakus 2008-04-18 05:50:26 EDT

*** This bug has been marked as a duplicate of 220481 ***

Note You need to log in before you can comment on or make changes to this bug.