Bug 220554 - gnome-python2-gtkmozembed is bork with firefox-1.5.0.9-1.fc6
gnome-python2-gtkmozembed is bork with firefox-1.5.0.9-1.fc6
Status: CLOSED DUPLICATE of bug 215163
Product: Fedora
Classification: Fedora
Component: gnome-python2 (Show other bugs)
6
All Linux
high Severity high
: ---
: ---
Assigned To: Matthew Barnes
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-21 20:38 EST by Bill Peck
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-30 14:00:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Peck 2006-12-21 20:38:18 EST
Description of problem:
any python apps that rely on import gtkmozembed
ImportError: libgtkembedmoz.so: cannot open shared object file: No such file or
directory

will not work.

Version-Release number of selected component (if applicable):
firefox-1.5.0.9-1.fc6
gnome-python2-gtkmozembed-2.14.2-5.fc6

How reproducible:
Everytime

Steps to Reproduce:
1. Upgrade firefox
2. use any python code that imports gtkmozembed
  
Actual results:
traceback

Additional info:

[bpeck@localhost ~]$ strings
/usr/lib/python2.4/site-packages/gtk-2.0/gtkmozembed.so |grep firefox-1.5
/usr/lib/firefox-1.5.0.8

notice the .8

[bpeck@localhost ~]$ rpm -q --requires gnome-python2-gtkmozembed-2.14.2-5.fc6
firefox >= 1.5.0.5
libatk-1.0.so.0  
libc.so.6  
libc.so.6(GLIBC_2.1.3)  
libcairo.so.2  
libdl.so.2  
libgdk-x11-2.0.so.0  
libgdk_pixbuf-2.0.so.0  
libglib-2.0.so.0  
libgmodule-2.0.so.0  
libgobject-2.0.so.0  
libgtk-x11-2.0.so.0  
libgtkembedmoz.so  
libm.so.6  
libnspr4.so  
libpango-1.0.so.0  
libpangocairo-1.0.so.0  
libplc4.so  
libplds4.so  
libpthread.so.0  
libxpcom.so  
python(abi) = 2.4
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rtld(GNU_HASH)  

The requires is wrong if the path is hardcoded to the version of mozilla that is
installed.
Comment 1 Matthew Barnes 2006-12-30 14:00:55 EST

*** This bug has been marked as a duplicate of 215163 ***

Note You need to log in before you can comment on or make changes to this bug.