Bug 215163 - traceback ImportError: libgtkembedmoz.so: cannot open shared object file: No such file or directory
traceback ImportError: libgtkembedmoz.so: cannot open shared object file: No ...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-python2-extras (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
: Reopened
: 214857 220432 220554 (view as bug list)
Depends On:
Blocks: 220432 236012
  Show dependency treegraph
 
Reported: 2006-11-11 13:56 EST by Jef Spaleta
Modified: 2007-11-30 17:11 EST (History)
6 users (show)

See Also:
Fixed In Version: gnome-python2-extras-2.14.2-6.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-11 11:16:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jef Spaleta 2006-11-11 13:56:40 EST
Summary: 
It appears that gnome-python2-extras needs to be rebuilt as an update to match
the latest firefox update.

+++ This bug was initially created as a clone of Bug #215131 +++

Description of problem:
ImportError: libgtkembedmoz.so: cannot open shared object file: No such file or
directory

Version-Release number of selected component (if applicable):
listen-0.5-8.beta1.fc6

on a fully updated fc6 system including firefox-1.5.0.8-1.fc6

does listen need to be rebuilt against the firefox update?

-- Additional comment from karlthered@gmail.com on 2006-11-11 07:20 EST --
No, it only requires gnome-python2-gtkmozembed (sub-package of
gnome-python2-extras) from core to be rebuilt.
I have rebuild gnome-python2-gtkmozembed against firefox-1.5.0.8 and it works
fine, but gnome-python2-gtkmozembed segfault bug still here (#205499)
I am not familiar with bug triaging, should I close or reassign it ?


-- New comment from Jef

Is there any eta with regard to a rebuild of gnome-python2-extras in Core?  I
understand there is an already occuring segfault issue with listen limiting its
functionality. But until gnome-python2-extras is rebuilt in Core to match the
firefox update, listen or any other python application that attempts to import
gtkembedmoz won't even start up.
Comment 1 Fedora Update System 2006-11-12 11:34:14 EST
gnome-python2-extras-2.14.2-5.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 2 Martin Sourada 2006-11-12 16:31:53 EST
*** Bug 214857 has been marked as a duplicate of this bug. ***
Comment 3 Jef Spaleta 2006-12-21 03:47:21 EST
its happened again.... a new firefox update.... has caused this problem once again.

Note the latest firefox update is now firefox-1.5.0.9-1.fc6
and places /usr/lib/firefox-1.5.0.9/libgtkembedmoz.so

We need a build of gnome-python2-extras to match the new firefox.  
Firefox's versioned library directory tree continues to be is a real real
problem since there is no way to trigger a rebuild of gnome-python2-extras with
each firefox update.  Please push an update of this again to match the new
firefox update. pretty please.

-jef
Comment 4 Matthew Barnes 2006-12-21 07:10:08 EST
I wonder why Firefox feels it necessary to install a directory that specifies
the version out to the, what would that be, nano number?

Is there a BuildRequires I could add to gnome-python2-extras that would flag
someone the next time the library location moves?
Comment 5 Matthew Barnes 2006-12-21 11:29:49 EST
*** Bug 220432 has been marked as a duplicate of this bug. ***
Comment 6 Matthew Barnes 2006-12-21 11:32:06 EST
Rebuilt and submitted directly to Fedora Updates (skipping Testing).
Comment 7 Fedora Update System 2006-12-21 14:53:56 EST
gnome-python2-extras-2.14.2-6.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 8 Matthew Barnes 2006-12-21 16:23:05 EST
Closing... 'til next time.
Comment 9 Matthew Barnes 2006-12-30 14:01:07 EST
*** Bug 220554 has been marked as a duplicate of this bug. ***
Comment 10 Jef Spaleta 2007-01-04 19:14:16 EST
(In reply to comment #8)
> Closing... 'til next time.

Just a thought. We could deal with this much more quickly if you used a
versioned requires on firefox in the spec file.  That way we would be able to
rely on scripts which look for broken dependancies.  The way the libraries are
packaged in firefox sneak around rpm's normal library dependancy checks and we
don't get a depchain breakage even though the directory those libraries are in
has moved.

My understanding is that soon, but not soon enough, firefox 3/xulrunner will fix
this versioned directory structure problem. But in the meantime a versioned
firefox dependancy is the best thing we can do to prevent users from seeing
missing library errors.

For example adding 
Requires: firefox = 1.5.0.9   
should restore the depchain breakage notification.

-jef
-jef
Comment 11 Matthew Barnes 2007-01-05 12:01:42 EST
Sounds like a good idea to me.  Linking to relevant discussion on
fedora-maintainers:

https://www.redhat.com/archives/fedora-maintainers/2007-January/msg00021.html

I tried rolling a new package with just such a requirement, but I'm having
problems with the build system at the moment.  I keep getting this error from
mock-helper:

Executing /usr/sbin/mock-helper yum --installroot
/var/lib/mock/dist-fc6-build-164210-32944/root resolvedep  'gnome-panel-devel >=
2.2.0' 'pygtk2-devel' 'gnome-python2 >= 2.9.0' 'gtkspell-devel >= 2.0.7'
'gtkhtml2-devel >= 2.3.1' 'python-devel' 'glib2 >= 2.6.0' 'gtk2 >= 2.4.0'
'firefox-devel = 1.5.0.9' 'libbonoboui-devel'
No Package Found for firefox-devel = 1.5.0.9
Comment 12 Kevin Fenzi 2007-04-10 22:35:51 EDT
Hey there. It's happening again. 

I thought about filing a new bug, but this one pretty much sums it up. 

The current gnome-python2-extras built against firefox 2.0.
The version currently in devel is 2.0.0.3.

This breaks gnome-python2-extras. 

Not sure why the Requires wasn't working in comment #11... 
I would think it would. 
Comment 13 Matthew Barnes 2007-04-11 11:16:25 EDT
Thanks for the heads up, Kevin.

This bug is for Fedora Core 6 and I believe we're still okay there, though this
is proving to be an ongoing problem.  I'll leave this in the MODIFIED state
until we're no longer updating Firefox in FC6.

I've opened bug #236012 to track this issue in Fedora 7.
Comment 14 Kevin Fenzi 2007-04-11 11:43:23 EDT
Excellent. Thanks Matthew for the quick response. 

Note You need to log in before you can comment on or make changes to this bug.