Bug 220673 - Pup crashes while retrieving update information
Pup crashes while retrieving update information
Status: CLOSED DUPLICATE of bug 224292
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-22 17:36 EST by Larry Spitz
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-25 13:34:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
exception captured (1.37 KB, text/plain)
2006-12-22 17:36 EST, Larry Spitz
no flags Details
Exception information saved from PUP crash (1.18 KB, application/octet-stream)
2007-01-25 05:26 EST, James Allerton-Austin
no flags Details
application state pirut/pup (1.18 KB, text/plain)
2007-01-25 10:14 EST, Martin P. Krimpelstätter
no flags Details

  None (edit)
Description Larry Spitz 2006-12-22 17:36:38 EST
Description of problem: Pup (package updater) causes exception while retrieving
update information


Version-Release number of selected component (if applicable):


How reproducible: Very


Steps to Reproduce:
1.Initiate Pup
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Larry Spitz 2006-12-22 17:36:38 EST
Created attachment 144318 [details]
exception captured
Comment 2 Harald Hoyer 2006-12-29 06:16:20 EST
$ rpm -qf $(which pup)
pirut-1.2.8-1.fc6
Comment 3 Jeremy Katz 2007-01-03 13:11:56 EST
Is your network connection working?  Do things work if you just run yum update?
Comment 4 James Allerton-Austin 2007-01-25 05:26:03 EST
Created attachment 146521 [details]
Exception information saved from PUP crash
Comment 5 James Allerton-Austin 2007-01-25 05:28:31 EST
Network connection working correctly and "yum update" works correctly.
Comment 6 Martin P. Krimpelstätter 2007-01-25 10:14:26 EST
Created attachment 146552 [details]
application state pirut/pup
Comment 7 Martin P. Krimpelstätter 2007-01-25 10:17:50 EST
Comment on attachment 146552 [details]
application state pirut/pup

Seems that I got the same exception as James. Network connection working
properly, yum update successful.
Comment 8 Vladimir Romantsov 2007-01-25 11:09:19 EST
I got the same exception! The problem in line from extra/comps.xml
<packagereq type="optinoal">digikamimageplugins</packagereq>

bad key word: OPTINOAL and
 /usr/lib/python2.4/site-packages/yum/comps.py", line 143, in parse_package_list
    raise CompsException
Comment 9 Vladimir Romantsov 2007-01-25 11:23:08 EST
Key word should be OPTIONAL, but in attachment 146552 [details] from Martin (genre: optinoal):

ile "/usr/lib/python2.4/site-packages/yum/comps.py", line 143, in parse_package_list
    raise CompsException
CompsException

Local variables in innermost frame:
genre: optinoal
self: Graphics
package: digikam
packagelist_elem: <Element 'packagelist' at 0x890a2d8>
child: <Element 'packagereq' at 0x890a248>
Comment 10 Jeremy Katz 2007-01-25 13:34:05 EST

*** This bug has been marked as a duplicate of 224292 ***

Note You need to log in before you can comment on or make changes to this bug.