Bug 220714 - Clicking ok or cancel on a bad pops server will crash
Clicking ok or cancel on a bad pops server will crash
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Matthew Barnes
:
: 214307 228524 231025 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-23 22:56 EST by Trever Adams
Modified: 2007-12-11 10:39 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-19 16:46:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Trace back (21.23 KB, text/plain)
2006-12-23 22:56 EST, Trever Adams
no flags Details
Newer trace back / Shouldn't have any unknown symbol tables (68.77 KB, text/plain)
2007-01-22 13:48 EST, Trever Adams
no flags Details
Trace back for clicking ok instead of cancel (65.62 KB, text/plain)
2007-01-22 13:58 EST, Trever Adams
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 362638 None None None Never

  None (edit)
Description Trever Adams 2006-12-23 22:56:59 EST
Description of problem:
If you connect to a server (such as I do) that uses a self signed cert, the
dialog asking if it is ok (cancel/ok as answers) now always comes up.
Additionally, clicking either answer not nearlya lways causes a crash. It will
ALWAYS crash if the send/receive email dialog is up.

Version-Release number of selected component (if applicable):
evolution-2.9.4-3.fc7


How reproducible:
Nearly every time.

Steps to Reproduce:
1. Set up a pops server with self signed cert
2. Send/receive email
3. Click ok or cancel on the dialog
4. Crash
  
Actual results:
Crash.

Expected results:
No crash.

Additional info:
Trace back attached.
Comment 1 Trever Adams 2006-12-23 22:56:59 EST
Created attachment 144337 [details]
Trace back
Comment 2 Trever Adams 2007-01-22 13:48:31 EST
Created attachment 146207 [details]
Newer trace back / Shouldn't have any unknown symbol tables
Comment 3 Trever Adams 2007-01-22 13:49:27 EST
Clicking ok seems fixed. Though this may have been just from me having the admin
regenerate the cert as it was expired. (Clicking cancel is what I did to create
the above trace back.)
Comment 4 Trever Adams 2007-01-22 13:58:14 EST
Created attachment 146209 [details]
Trace back for clicking ok instead of cancel

146207 is for clicking cancel, this is for clicking ok.
Comment 5 Matthew Barnes 2007-01-22 14:49:41 EST
Confirmed, I'm able to reproduce this.  I don't think it's directly related to
certificates, but that certificate dialog does send it down a code path that
triggers the problem.  Looks like memory corruption to me.  Investigating.
Comment 6 Matthew Barnes 2007-02-13 12:04:51 EST
*** Bug 228524 has been marked as a duplicate of this bug. ***
Comment 7 Matthew Barnes 2007-02-15 18:46:43 EST
I think I may have found the problem.  It looks like an error in some threading
logic I rewrote awhile back.  An upstream bug [1] has all the gory details about
the source of the problem and the solution.

Please give evolution-2.9.91-3.fc7 a try.  It should appear in Rawhide tomorrow.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=362638
Comment 8 Trever Adams 2007-02-16 18:52:32 EST
At the moment this appears it may be fixed. However, I have occasionally had
success before so, give me another day or so to make sure.
Comment 9 Trever Adams 2007-02-19 16:46:48 EST
I have only been able to get one crash. It seems unrelated (NEtworkManager
wouldn't setup the network and leave it, so I removed it again, having just
installed it) so I am closing the bug.
Comment 10 Matthew Barnes 2007-03-15 14:50:08 EDT
*** Bug 214307 has been marked as a duplicate of this bug. ***
Comment 11 Matthew Barnes 2007-12-11 10:39:27 EST
*** Bug 231025 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.